Bimmerfest BMW banner

1 - 8 of 8 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
hi i have a 2005 bmw 545i and I am getting vanos fault codes.
i am not using the best scan tool (creator c110)... waiting for my INPA to arrive in the mail

the codes i am getting are
2A88 exhaust vanos
2A89 exhaust vanos bank 2
2a83 intake vanos
(forget code) intake vanos bank 2

symptoms
erratic idle on start up almost to the point of stalling
idle fluctuation at lights anywhere in between 500-700rpm
a lot of vibration and engine shaking
loss of power around 3000rpm
ticking noise when hitting around 2500 - 3000km then goes away when you take the foot off the gas. sound like its almost coming from the valvetronic motor on bank 1

work done (while the vanos solenoid problem was still there)
Bank 1 & 2 valve cover, timing cover gaskets replace
bank 1 & 2 valvetronic motor gaskets
bank 1 & 2 eccentric shaft sensor gaskets
vacuum pump gasket
throttle body gasket



Things i have done to try and fix the problem

1: cleaned all vanos solenoids -- Did not work
2: switched bank 1 and bank 2 (someone suggested) -- Did not work -- Did not work
3: second hand banks 2 vanos (from a friends car the we know work) -- Did not work
4: new sockets and pins (notices all the wires almost broken off all connector's) -- Did notwork

Vanos exhaust position cyl 1-4 & 5-8 stays at 102.4 at idle and while driving
Vanos inlet position cyl 1-4 & 5-8 stay at 102.4 at idle and while driving

Vanos exhaust adaptation exhaust cyl 1-4 stay at 102.4 at idle and while driving
Vanos exhaust adaptation exhaust cyl 5-8 stay at 128.0 at idle and while driving
Vanos inlet adaptation cyl 1-4 & 5-8 stay at 51.2 at idle and while driving


could the camshaft position sensor (intake & exhaust cause these fault codes)
i saw on another forum that the oil pressure sensor could cause issues with dissipating the amount of oil that is actually getting to the vanos solenoids (could this happen?)

any other software i should get other then INPA
any help would be much appreciated!
 

·
Registered
Joined
·
5,787 Posts
Disconnect unplug the vanos solenoids , all four , then start the car and see how she runs .
By disconnecting the solinoids it will disable the valvetronics . Give it give it a shot and lets us know the results .
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
I did this and the car ran quite a bit better, but still have a slight idle problem not as bad


Sent from my iPhone using Bimmerfest
 

·
Registered
Joined
·
2,428 Posts
What sort of mileage is on the car? Vanos solenoids do need to be replaced around the 250K km mark even with regular oil changes. If the previous owner(s) skimped or followed the 25K km condition based service, then I would expect the Vanos solenoids to have to be replaced much sooner.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
What sort of mileage is on the car? Vanos solenoids do need to be replaced around the 250K km mark even with regular oil changes. If the previous owner(s) skimped or followed the 25K km condition based service, then I would expect the Vanos solenoids to have to be replaced much sooner.


It had 175,000 km when I bought it and it has 183,000 km the car was parked for about 1-2 years at a dealership when purchased it


Sent from my iPhone using Bimmerfest mobile app
 

·
30FF <3
Joined
·
2,619 Posts
Did you re initialize the valvetronic motors after the VC gasket repair ?
I didn't have to do this, and read multiple places that this is automactically done with the car starts...

I just did a VCG job and no errors on my valvetronic...
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
Did you re initialize the valvetronic motors after the VC gasket repair ?


I did the turn the key ones and listen for the clicking noise to here them register... but this problem has been there for a while and been trying to figure it out with out taking it to a mechanic. I did that with my last bmw and never again will I let someone else touch my car lol. Did valve covers and timing covers due to waking up one morning and bank 1 leaked all over my garage then 2 days later the other side did the same thing.


Sent from my iPhone using Bimmerfest mobile app
 
1 - 8 of 8 Posts
Top