BimmerFest BMW Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 1995 325i. It started acting up about a couple of weeks ago. It was throwing out the O2 sensor coed so i changed that.. Now it's still throwing it and it's still runiing like ****. Whenever I step on the gas, it just barely responds and does not accelarate at all. It feels like it was bogging out. I have changed the MAF sensor already and the O2 sensor. I took it to a shop and they are trying to tell me that it might be a clogged catalytic converter. (which i also told them) and now they are tryin to charge me 1600 to change it. Now the car is stuck at the shop because it won't start at all. It cranks but just doesn't seem to want to start at all. PLEASE HELP!
 

·
Registered Non-OP
Joined
·
14,496 Posts
There are a few O2 sensors, how many did you change?
 

·
Make your own Luck
Joined
·
1,814 Posts
Welcome to the fest'


You should read this thread

" READ BEFORE POSTING: How To Ask Smart Questions (or, Dealing With The Oldschool Guys)"
To avoid any conflicts. Because a title like that is not very attractive -_- . Idk how to resolve your problem, but hopefully one of the BMW genius' aka "oldschool guys" on here can help you.:thumbup:
 

·
Registered
Joined
·
4,667 Posts
Get a new cat if its blocked? Or take it to a muffler shop and just put some glass packs in.
 

·
I Am The Machine
Joined
·
20,931 Posts
Usama, there's only one O2 on OBDIs bro. :AF330i:

Dee, what's your driving style like? Are you a very conservative driver that mostly just makes very short trips? It could be a number of things. Primarily, which code are you getting? The O2 bad code or the Lambda control code? Give us the number please.
 

·
Registered Non-OP
Joined
·
14,496 Posts
I knew that


(I coulda sworn I saw a couple on mine when it was on the lift. I blame it on my cold...
)
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
well... i drive to work, home, and anywhere else. it's my primary car. it was throwing code 1221. but now, it's just throwing code 1. would it have anything to do with my gas relay or anything along those lines?
 

·
I Am The Machine
Joined
·
20,931 Posts
well... i drive to work, home, and anywhere else. it's my primary car. it was throwing code 1221. but now, it's just throwing code 1. would it have anything to do with my gas relay or anything along those lines?
Code 1 (actually, it's called code 1000) means it's the end of the codes and you can reset them by holding the pedal for 10+ seconds. I don't know how it is on E36s, but on my E34 you have to push the pedal 5 times after each code to advance to the next code or it keeps repeating the same code over again. You might want to try that.

One thing that's fairly simple is to try checking for fuel pressure. Perhaps you have a bad pump or clogged filters. Those are like $15 from Pelican Parts and a relatively easy DIY install.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Code 1 (actually, it's called code 1000) means it's the end of the codes and you can reset them by holding the pedal for 10+ seconds. I don't know how it is on E36s, but on my E34 you have to push the pedal 5 times after each code to advance to the next code or it keeps repeating the same code over again. You might want to try that.

One thing that's fairly simple is to try checking for fuel pressure. Perhaps you have a bad pump or clogged filters. Those are like $15 from Pelican Parts and a relatively easy DIY install.
yes, that is the way i check for my codes. all it throws is code 1 (1000). then when i hold the pedal down for the 10 secs. it the check engine stops blinking. after that, i try to read the codes again by putting the key on the on position and pumping the gas 5 times. thats when it starts to throw code 1444. anyone? please help. i'm a noob to bmws.
 
1 - 9 of 9 Posts
Top