BimmerFest BMW Forum banner

Power seat switch failure

21919 Views 8 Replies 6 Participants Last post by  lild
My searches are not turning anything up. Hope someone can help.

My 1998 540i power seats have started failing. I don't think it is the motors because it works sometimes. First the memory functions started failing and then the switches started not responding. This is only on the driver seat. I don't have seat heaters if that matters.

Has anyone experienced this? Should I just start replacing the switches or is there something else I should look at.

Thanks in advance,
Dave
1 - 9 of 9 Posts
most likely the switches are going bad. it could be the memory ones that may be causeing you problems, see they only work for the drivers seat. one day, nothing on seats would work. so when i got home i turn the car off. got out locked it, unlocked it, got back inside, all was fine. you know sometimes these cars have pms.
Hows the plastic cover around the base of your driver's seat? Is it broken in the front or back? Is it falling away from the seat? Does it move when you get in and out? If yes, the issue coud be that the electrical connector to the seat is breaking away from the switch...this is a somewhat common issue...especially when the seat stops working intermittently along with the steering wheel.

Click this link...which has other links to the same type of issue you may be having: http://www.bimmerfest.com/forums/showpost.php?p=3906972&postcount=2

You can also find an extensive write up with lots of pics if you search for "seat switch"...by user "Bluebee"....on the "e39 forum". She took lots of great pics on how to undo the plastic seat cover (at the base of the driver's seat) to access the driver's seat switch...and you can even see her cracked seat switch which allowed the harness to slip out of the connector:

(example of one of Bluebee's images)


(close-up of broken seat switch)
My searches are not turning anything up. Hope someone can help.

My 1998 540i power seats have started failing. I don't think it is the motors because it works sometimes. First the memory functions started failing and then the switches started not responding. This is only on the driver seat. I don't have seat heaters if that matters.

Has anyone experienced this? Should I just start replacing the switches or is there something else I should look at.

Thanks in advance,
Dave
Since we***8217;re on the subject my knee extender stopped working for quiet sometime, but all other switches works fine. Are there two motors in the seat?? Or it***8217;s a simple swith??
Pop the side seat panel off, and you'll see the receiving end of the harness (where the harness plugs into) is cracked and is unable to HOLD the switch (harness) in place. Hold the wire in with your hand and attempt to move the seat. You'll see it will work fine. I took some Crazy Glue and plugged the harness in TIGHT to the side panel where it plugs into, and liberally applied crazy glue. Has been fine for MONTHS. No more dead seat. Of course if you want to do it the right way, buy a new panel.
didn't see the link for removing plastic from the sunroof.:rofl::D
Crazy glue.
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top