BimmerFest BMW Forum banner

1 - 7 of 7 Posts

·
Wish I was in Toronto
Joined
·
2,774 Posts
Discussion Starter #1
I'm driving to work, slowly on a local street, and the battery light blinks on and off a few times. On for like 2 seconds and then off for 5, repeat...

Driving home and it starts to come on and stay on more. After driving longer I think it seems to only happen when the car is in gear and above 2k. If in neutral I *can* get it to come on but I have to rev it up past 2.5k and my car is loud there and I have no reason to rev in neutral so I don't notice it then.

Any ideas? Is the alternator going?


Car is an E46, 2000 323Ci with < 70k
 

·
Wish I was in Toronto
Joined
·
2,774 Posts
Discussion Starter #3
iateyourcheese said:
Sounds to me like an alternator. Got a multimeter?
I believe I have access to one yes

figures I lose my Bentley book just when I really need it
 

·
Nerd
Joined
·
1,432 Posts
ACS-B said:
I believe I have access to one yes

figures I lose my Bentley book just when I really need it
Hmmm... I may have to punt on this one. On my last car I was able to measure the voltage off of the alternator. I just looked at my 330i and the alternator is not something you can get to easily. I assume it's the same with your 323i.
 

·
Registered
Joined
·
2 Posts
i have had that problem before but i had my problem fixed easily, check to make sure the battery terminals are secure. on my 323i they were just a little loose and the car went nuts, same things were happening, and the battery wasn't getting a good charge because of it. when you are checking ur battery terminal's snugness, i suggest cleaning the batter posts as well.
 

·
Registered
Joined
·
12 Posts
Had my battery replaced this weekend and thought this had corrected it. Mechanic was 99% sure. Went to work the next morning, no problems. Driving home the lights started blinking. Red battery indicator when over 2500 rpm, yellow ABS, brake, and DSC warnings when under. It deteriorated quickly after this and I ended up in emergency drive on 19th avenue. Made it across the golden gate bridge before the warning lights went red and the car died shortly after. Waiting for the tow on the edge of the 101 with rain coming down......and to top it off I had a carpool buddy and his son with me!

Anyway, had it towed to San Rafael and found the alternator had failed. It must have slowly died as the previous mechanic did not see anything funny when he was measuring output after battery replacement. Anyway, I hope that is all for this problem!

Not sure if original poster had same resolution. I had pm'ed him to see what he had found last week.
 
1 - 7 of 7 Posts
Top