BimmerFest BMW Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have proplem on my bmw 728il if i start my car quickly my car dosent start quickly and if i put the key on position 2 and let pump work for a seconds and i start it it works fine .. and if i turn off car and quickly started its be ok
And if the car after driving turned off and still 30 minutes my car do the same proplem not working after i but on 2 position it works ?

This proplem have a long time but iam let it iam used to put key on position 2 untill pump works for seconds reach fuel to engine and it works with
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
I have proplem on my bmw 728il if i start my car quickly my car dosent start quickly and if i put the key on position 2 and let pump work for a seconds and i start it it works fine .. and if i turn off car and quickly started its be ok
And if the car after driving turned off and still 30 minutes my car do the same proplem not working after i but on 2 position it works ?

This proplem have a long time but iam let it iam used to put key on position 2 untill pump works for seconds reach fuel to engine and it works with
 

·
Registered
Joined
·
320 Posts
Could be a variety of things. You need to get the codes and tell us. If you hack no codes, start with fuel filter and pump. Miles and service history?
 

·
Certifiable BMW Whackjob!
Joined
·
6,002 Posts
+1 noodles
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I have changed pump and fuel filter they have 2 years and filter not genuine its germany class 2
No codes ... 300km ... there is people say its maybe the engine temperature sensor because if car reach normal heat and i turn off my car and turn it on he do the proplem and they told me this sensor do it ... is this right or not ?

And if my car cold its turn on quickly
 

·
Registered
Joined
·
320 Posts
Ok - the info about cold start helps. It could be the sensor. You should be able to find the specification for the sensor once you have a part #. These usually have a resistance that is measured in ohms, but you need to know what is a good value, and what is out of spec.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Noodlesandsam can i have your email or your facebook ? And thanks for replay i want show you video for proplem
 

·
Registered
Joined
·
320 Posts
I listened to those vids - I replied, but I don't think it is a sensor. Once it starts, it sounds very normal. Does it always start, or is there a condition it will not start? If there are times it takes longer to start, it almost sounds like you are losing fuel pressure.
 
1 - 9 of 9 Posts
Top