BimmerFest BMW Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Hello. I have finally bought my long planned/dreamed BMW two weeks ago. It isa 2002 325i with topaz blue color. I love it despite some of the really unfortunate events happened. On the first day I bought the car, I was driving on my way from the dealer to my home and car stalled and stopped on the highway!!! What a start huh?! I got the car towed to the service (it still has one more year warranty left thank god!). They first said it is just the battery and called me that it is ready to pick up. When I went to pick up the car, it did not start! After an extensive look at the car, they realized that there was no gas in the tank!!! This was the case despite the fact that fuel gauge was showing that tank was half full. They said both of the fuel sending units were messed up and fixed it.

Now the car drives nice with no problem probably. I say probably because this experience caused me develop this paranoia that I feel like I hear an abnormal sound coming from the engine while I am driving. It is like a whistling sound which is there even when I am stopped, for example, at a traffic light, etc. Maybe it is normal because this is my first BMW but I am not sure. Also is it normal to see the EML light to appear for a second when I turn the ignition key. In addition to EML, SES light also appears sometimes and disappears in a second.I do not see them while driving. I saw SES for a few seconds while driving the other day. I took the car to the service. They read the code and said yes I was right that it came out for a short time (so I was not lying!) but they do not see anything wrong and they need to see it happen for about 10 times before they change anything.

Any idea/opinion about whether these are likely to be normal or I should stop being over suspicious over some of these things.

Cheers,
Ed
 

·
Banned
Joined
·
0 Posts
Sounds odd. If you have no runnability probs (anymore), I would just do what the dealer said, and wait for it to reoccur. The important thing is that it was recorded at the dealer, and the prob should be rectifed even if/when the car goes out of warranty (IIRC).
 

·
Premium Member
2022 540i MSport
Joined
·
9,687 Posts
Do you have a 30-day total guarantee? I would think about returning the car and finding another... Was it advertised as CPO? They obviously have done nothing to prep the car for delivery, IMO, and don't sound very concerned about fixing anything, now, or most likely, in the future. My EML and SES lights come on only when I turn the ignition on while starting up. If they checked your SES and know it came on, ask what specific codes they found -- that will tell them and you what the issue was. I have a 330i and there's no whistling sound, I don't think the 325i would have that noise either. (Although there was another thread the other day about an X5 owner with the 3.0L who hears a whistling noise from his). Did you test drive it extensively before purchasing??
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top