BimmerFest BMW Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 · (Edited)
Hello,

My radio regularly lose its DAB signal. Personally I think the signal is just fine because I can be in the same place on different days, and sometimes I have a signal and sometimes I don't.

Anyone with an opinion? I also think that when on FM radio it fails to re-tune to the strongest signal.


Thanks


Stephen
 

·
Registered
Joined
·
2 Posts
Did you (or anyone else) ever find the cause or cure for this problem? It's just starting happening on mine. Odd because it's been fine for the 2 years I've owned it then, yesterday, it was searching for a signal much more than playing the DAB radio.
Z4 28i 2014
Thanks. Brian
 

·
Registered
Joined
·
38 Posts
DAB radio is as much use as a bucket with a hole in it! If you are stationary and get a signal then fine but as soon as you move you get the error message. I cant personally see any difference between FM and DAB but maybe that's just me?
 

·
Registered
Joined
·
2 Posts
If that's the case, my bucket has been completely holeless since purchase but has developed a leak now.

DAB radio reception has been excellent until my original post. Since then, it's been showing 4 bars on the signal strength meter but with "No Signal" against it and no sound at all.

Any ideas?

Brian
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top