BimmerFest BMW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Purchased a 02 745li that is a recovered vehicle. I get sound out of only one speaker and it;s not audible. Scratchy, low volume. BMW thinks its the amplifier for 1600. Does anyone have experience with this problem? Also, is the amplifier located in the trunk and then where is the actual radio located? Thanks
 

·
the cleanest1
Joined
·
2,632 Posts
You will most likely end up changing the amp and the ask unit(dash cd player). There are alot of threads on here about thats stuff. ASK unit and AMP will run 3K from the dealer + 350 to get it all hooked up if not more. Look into getting aftermarket sound system
 

·
Registered
Joined
·
62 Posts
First get your amp checked out. Don't assume that It's bad. I was thinking the same thing until I had a sound shop check out my amp...a little tweak here and there and bingo, all my sound was back! First and foremost, the Amp does not control all of the speakers. Sound is split between the AMp and the radio. So if you have only 1 speaker playing, there is something else going on...Your radio and your amp is failing. Its most likely some wiring issue. again have it check out by someone who knows about BMWs...

A bit of advice, Dont go into a shop and say "I think my factory system is shot, I want to go aftermarket" Because the shop will not put the effort into trouble shooting your stock system since there is much more money to be made by you buying their aftermarket stuff...

Go into the shop and say, "I want my factory system repaired" This will force the shop to focus on your needs instead of their wants.
 
1 - 6 of 6 Posts
Top