BimmerFest BMW Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,913 Posts
Discussion Starter · #1 ·
I replaced my rotors and pads on Wednesday and had a accident involving being hit in the rear on Friday. My right rear brake now makes a thud, thud, thud sound now when applying moderate to heavy brake pressure. It makes no noise when applying light brake pressure. I took the caliper off today and looked at everything on the brake but see no problem. Any ideas? Wheel bearing?


Sent from my iPhone using BimmerApp
 

·
Registered
Joined
·
151 Posts
I replaced my rotors and pads on Wednesday and had a accident involving being hit in the rear on Friday. My right rear brake now makes a thud, thud, thud sound now when applying moderate to heavy brake pressure. It makes no noise when applying light brake pressure. I took the caliper off today and looked at everything on the brake but see no problem. Any ideas? Wheel bearing?

Sent from my iPhone using BimmerApp
Yeah sounds like your rear control arm bushings might have busted up after the impact.
 

·
Registered
Joined
·
1,913 Posts
Discussion Starter · #4 ·
I just finished taking the passenger side wheel off for the third time today. I tried switching wheels but it made no difference. I took the caliper off, checked the pads and the rotor but everything looks fine. I looked at the bushings and see no cracks or anything odd. Could it be in the cv boot coming off the rear axle? Sounds like thud, thud, thud when applying brakes medium to hard. No sound when applying brakes lightly.


Sent from my iPhone using BimmerApp
 

·
Registered
Joined
·
367 Posts
I just finished taking the passenger side wheel off for the third time today. I tried switching wheels but it made no difference. I took the caliper off, checked the pads and the rotor but everything looks fine. I looked at the bushings and see no cracks or anything odd. Could it be in the cv boot coming off the rear axle? Sounds like thud, thud, thud when applying brakes medium to hard. No sound when applying brakes lightly.

Sent from my iPhone using BimmerApp
yep same exact thing
 

·
Registered
Joined
·
1,913 Posts
Discussion Starter · #6 ·
yep same exact thing
How do you know it is the control arms? Did you take it in to the shop and they told you this? Do you have a picture of the part you suspect is bad? Thanks for the help.

Sent from my iPhone using BimmerApp
 

·
Registered
Joined
·
1,688 Posts
if you had a lift I'd say put it up and try to flex the arms with a pry bar, that should tell you if you have any bad bushings.
 

·
Registered
Joined
·
367 Posts
yes i told them about the noise and the guy checked it he said he will charge me 40 bux to put them on but i have to order them that's why its not done yet because i don't know what brand is good from bad
 
1 - 9 of 9 Posts
Top