Bimmerfest BMW banner

1 - 20 of 107 Posts

·
Moderator
Joined
·
2,520 Posts
Discussion Starter #1 (Edited)
Here it is ....since sticky is overcrowded with too much traffic we wanted a workspace to work on this issue alone.



This is mainly a techinical thread


Pre-requisites:


Drive Assistence package (Lane Departure warning, High Beam Assistence)



What we did so far:


1) 8TH to VO
2) HU_CIC, 3001 EXBOX, SPEEDLIMIT_INFO = aktiv
3) KOMBI, 3000 Anzeige_Konfiguration, SPEED LIMIT GENERATION = sli_gen2
4) KOMBI, 3003 FZG_Ausstattung, SPEED_LIMIT = aktiv
5) KAFAS, 3010 SLI_CODING, SLI_ON_OFF = SLI_ON
6) KAFAS, 3010 SLI_CODING, CODE_ELECTRIC_HORIZON = nicht_aktiv
7) KAFAS, 3010 SLI_CODING, Country_code_display = wert_3
8) KAFAS, 3010 SLI_CODING, UNIT DISPLAY = wert_4
9) KAFAS, 3020 KAFAS_COMMON, COUNTRY_VARIATION = wert_3
10) Turned on Speed Limit Info in the display.


This wil read speed limits once in a while but the speed limit info stays for few seconds only...

enabling CODE_ELECTRIC_HORIZON makes the icon stay permanently but the car stops reading the speed limits. All our cars comes with CEH active whihc gives us a feeling that it must me activ and there are osme other dependent parameters whihc are required to be configured
 

·
Moderator
Joined
·
2,520 Posts
Discussion Starter #2 (Edited)
I think we need additional software/algorithm to make it 100%.. Which i assume will come if you get the gloabl update.. as i believe the 2013 5 series will come with that data set....



I want to be gunea pig for this test update the VO with 8TH and go for gloabl update ... I am assesing the consequences!
 

·
Registered User
Joined
·
356 Posts
DreamCar:

I don't have Highbeam Assistance. It was not an option when I ordered my car. I might try changing the VO to add it.
 

·
Moderator
Joined
·
2,520 Posts
Discussion Starter #4 (Edited)
Sharbot,

We are not sure if we really need high beam asistence...

Wait for Hans to respond... if he doesnt have HBA then youodnt have to add that
 

·
Registered
Joined
·
465 Posts
I need almost the reverse of this…

My F10 already has Speed Limit Info (8TH) and Auto-Head Light (5AC); but I did not order the Lane Departure Warning system (LDW)?

Any ideas as to how LDW could be enabled? I read that everyone believes the necessary hardware for all 3 items is the same. SInce I have the necessary hardware; any help to enable the LDW would be much appreciated.

- I am based in the UK, car model will be 2012 F10.
 

·
Moderator
Joined
·
2,520 Posts
Discussion Starter #7
gspannu,

Did you get the car yet?

I think you need to work around KAFAS... Its basically for all camera related configuration
 

·
Registered
Joined
·
120 Posts
Here it is ....since sticky is overcrowded with too much traffic we wanted a workspace to work on this issue alone.



This is mainly a techinical thread


Pre-requisites:


Drive Assistence package (Lane Departure warning, High Beam Assistence)



What we did so far:


1) 8TH to VO
2) HU_CIC, 3001 EXBOX, SPEEDLIMIT_INFO = aktiv
3) KOMBI, 3000 Anzeige_Konfiguration, SPEED LIMIT GENERATION = sli_gen2
4) KOMBI, 3003 FZG_Ausstattung, SPEED_LIMIT = aktiv
5) KAFAS, 3010 SLI_CODING, SLI_ON_OFF = SLI_ON
6) KAFAS, 3010 SLI_CODING, CODE_ELECTRIC_HORIZON = nicht_aktiv
7) KAFAS, 3010 SLI_CODING, Country_code_display = wert_3
8) KAFAS, 3010 SLI_CODING, UNIT DISPLAY = wert_4
9) KAFAS, 3020 KAFAS_COMMON, COUNTRY_VARIATION = wert_3
10) Turned on Speed Limit Info in the display.


This wil read speed limits once in a while but the speed limit info stays for few seconds only...

enabling CODE_ELECTRIC_HORIZON makes the icon stay permanently but the car stops reading the speed limits. All our cars comes with CEH active whihc gives us a feeling that it must me activ and there are osme other dependent parameters whihc are required to be configured

I just added 8TH to my VO...
next step was pressing the "code" button for the 3 CAFD's (HU_CIC, KOMBI, KAFAS)
items 2, 4-9 were set correctly/automatically after coding, item 3 was the only one that was unchanged, which I then edited the FDL and did a code FDL.

***EDIT*** COD_ELECTRIC_HORIZON defaults to aktiv

I get the not "supported in this country" message...
I have the square with 3 dashes in it...

is it possible that there is another ECU that needs coding?
 

·
Moderator
Joined
·
2,520 Posts
Discussion Starter #10 (Edited)
MJGood,

Did you use Code with calculate ? We didnt do code .. we basically edited the FDL and did FDL coding
did you change the SLI_generation?
 

·
Registered
Joined
·
120 Posts
I don't calculate, just code the 'blue' CAFD with the green check... Without coding, adding to the VO really isn't doing anything... This way everything sticks permanently and all the required parameters are getting changed automatically...I'm just reluctant to code the whole car, I'd rather only code the affected ECU's... My car is at ISTA-P 39, may need to go to 46.3 to get support for US signs....

I changed the sli_genertaion as well as toggling the electric_horizon, still get no speed limit for this country...
 

·
Registered
Joined
·
120 Posts
I'm still trying to figure all this out...
I think by just coding the CAF from the 'read VCM' it's just changing the available FDL entries... Is calculating the SVT Actual/Target updating the SWFL and adding new FDL entries?

The guide is pretty good, but still incomplete...

In a nutshell, I'm not sure I'm getting all the CAF's, but the FDL parameters are getting automatically changed to match what you guys have been finding, and if I re-code I'm not losing and having to re-enter FDL..

I worked on mainframe computers all my life, this stuff is definitely giving me some brain exercise....
 

·
Registered
Joined
·
120 Posts
I went to the mall and back, 10 miles each way and plenty of signs... nothing

I'll get back on it tomorrow, I'll try comparing/updating SWFL's and see if that gets anywhere...
 

·
Registered
Joined
·
120 Posts
@DreamCar.... I was re-reading the E-Sys documentation regarding coding, pages 10 & 11...

I think what it's saying is:
If the CAFD has a green check it can be coded
If you want to code the target CAFD that has a red x, then the target CAFD needs to be programmed with the target SWFL first.. otherwise code with the actual version (green check).

any thoughts on this..... thanks
 

·
Moderator
Joined
·
2,520 Posts
Discussion Starter #17
MJ,
I read it and tried it.
After I updated the VO I ran the calculation and I found bunch of the modules has this red cross so didn't proceed ...

As of now only see two exits either we run calculation using 46.3 data files and code using esys.

Or take it to dealer with updated VO for global update and see if we get the updated modules for sli

Not sure if either of these will actually work.
 

·
Registered
Joined
·
120 Posts
At this point, I'm thinking the dealer route as you suggested may be the way to go...

sadly, it's almost impossible to get a global update...
 

·
Moderator
Joined
·
2,520 Posts
Discussion Starter #19 (Edited)
I heard even 550's are also eligible for global update..

Anyways one of the member i know is going to get this update soon .. we will have a better understandig once he gets his car.


Did you do any test runs? any luck?
 

·
Registered User
Joined
·
356 Posts
I just got an appointment at my dealer to have the "hesitation and rough idle" issue looked into. "There has been a number of new updates made available since you last visit" (quote from service rep over the phone). So I'm hoping to get the global installed. The bad news I'm in europe next week and I'm not scheduled to drop the car off until Monday June 11th. I'm hoping to see what effects the update may have on any of our efforts to code the SLI.
 
1 - 20 of 107 Posts
Top