BimmerFest BMW Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I recently bought a 2007 335i dark blue and cream interior. i first drove it the next day and wanted to fill up with gas. As i made my way i noted the classic bad alternator issue of radio and speedometer going crazy. it would not start till a jump but died right after the cables were taken off the terminals. Had it towed and have good BMW repair shop fixing and i should get it back today monday. They said the are replacing the alternator and battery saying the dealer while putting a new battery in the car it was the wrong one and didn't program the computer that they had replaced the battery.

questions

1} would the issue with the alternator cause a bogging symptom? it felt like the brakes were locking. Had high revving but no speed. The ABS light was on as well.

2} When i use the petal shifting it goes back to D, Drive when i don't continue to shift with the petals. Is that normal, if so what are some of your experiences with the petal shifting?

3} This 335i red lines and 7.5 i think. It seemed to run better at the higher RPM's but i don't what the risk that can come with running at higher RPM's . With this engine what are the risk of running at high RPM's constantly ?

Thx
John
 

·
Banned
Joined
·
10,015 Posts
.

What's the mileage since last battery replacement? Alternator bad would be very very unusual....could be they were covering all bases while maximizing July income. Did they tell you how it was diagnosed, and demo the result?

[here] is how to diagnose a number of things.

Was jump started [here], correct?

Carly App easily registers a battery from a cell phone.

[here] is what I did.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
The dealer put a new battery in a few days before i bought the car last Wednesday drove it Thursday when it died, So not many miles on the dealer battery. I don't know when it was replaced before then. Why do you feel its NOT a alternator issue? This BMW/Mercedes auto repair shop said the alternator registered very low volts so low it was bad and they said the battery the dealer put on a few days ago was the wrong kind. So the alternator was tested bad.
 

·
Banned
Joined
·
10,015 Posts
The dealer put a new battery in a few days before i bought the car last Wednesday drove it Thursday when it died, So not many miles on the dealer battery. I don't know when it was replaced before then. Why do you feel its NOT a alternator issue? This BMW/Mercedes auto repair shop said the alternator registered very low volts so low it was bad and they said the battery the dealer put on a few days ago was the wrong kind. So the alternator was tested bad.
Not saying they're wrong, just that it's very unusual.

Click troubleshootin' link; test for parasitic drain. Might be the alternator, or maybe there's an external diode pack. Testing & detective work will find the problem part.
 
1 - 4 of 4 Posts
Top