Bimmerfest BMW banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello,

2008 X3 just began to run rough on idle stop and gives a jumpy start when accelerating from a stop or pass on highway. I do not have a CEL on.
I do have a Service Engine Soon light on.

Codes thrown are: 00303 & P00306 misfires on (coils #3 and #6),

P116E MAF sensor

P1771 Throttle Position Sensor

Question: Did the P116E and/or P1771 cause the misfires, or did the misfires cause the MAF and TPS to throw codes? Any thought would be appreciated!
 

·
Registered
Joined
·
5,349 Posts
The MAF data combined with data from the pre-catalytic converter oxygen sensors is how the engine computer (DME in BMWspeak) manages the engine’s performance. The throttle position sensor provides feedback to the DME as to how “open” the throttle is. However, these issues would impact overall performance and not just that of 2 cylinders, typically.

The misfires on 2 cylinders could be caused by:
- bad spark plugs
- bad coils
- bad injectors
- leaking intake manifold gasket (unlikely as you didn’t get P0171/0174)

Label the coils and then swap the coil from ONE of the misbehaving cylinders with a properly running cylinder. Clear the codes and see what codes show up. If the code moves to the previously properly running cylinder then you know the coil is the culprit. Repeat for the other cylinder. If 1 or more coils are bad I recommend that you replace all the coils. How many miles on the spark plugs?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Hey there! I replaced all coils and plugs with Bosch brand and all is great! X3 running like new now. Appreciate the input and direction from you and others that replied!
 
1 - 3 of 3 Posts
Top