Bimmerfest BMW banner

1 - 20 of 52 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1 (Edited)
Replaced alternator but now idol is rough and rpms keep dropping can't go faster then 40 mph. What am I missing? Trued reset by ignition and trip button some dash lights reset but not all
 

·
Registered
Joined
·
545 Posts
is there any chance that maybe when you replaced the alternator that pinched or chaffed a wire ...look really good...
 

·
Registered
Joined
·
545 Posts
got a picture..dsounds like a big vacuum leak

what year...what engine do you have..

i have a 2000 540i with a 4.4...if yours is a 4.4 then our SAS routings will be pretty close..
 

·
Registered
Joined
·
545 Posts
I understand.. And feel your pain.. Working on cars is not like it was when carburetors were the thing... Bimmers are complicated creatures.. If you plan on doing your own on Bimmers.. I would highly recommend getting some diagnostic software.. And a laptop dedicated to only your Bimmer... It will make troubleshooting so much easier.. Plus you'll be able to code your own replacement parts..

It can be very frustrating.. But stick with it and you start to learn the bugs and fixes... The only one I'm really scared of on my 06 is the transmission going out.. It has started to kick a bit from 1st to 2nd shift... And needs a mechatronics unit rebuild

Sent from my S8 Active
 

·
Registered
Joined
·
545 Posts
It only showed up as a picture not a video... Since it's idling g badly that has to be the source of the vacuum leak but I can't make anything out that close... Try backing up and taking wider pic

Sent from my S8 Active
 
1 - 20 of 52 Posts
Top