Bimmerfest BMW banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Okay so I have seen this in several other forums about this happening and everyone saying a multitude of different things. I have a bmw e46 325ci 2003. I don***8217;t know what it is I have scanned for any trouble codes and have not found anything. Basically I***8217;m driving at a normal speed (around 40mph) then the car will have an rpm drop and have a vibration attached to it. I know it***8217;s not transmission because if it where transmission the rpms would surge and go up. I have replaced the fuel pressure regulator/ fuel filter and I have put in bed spark plugs (NGK laser platinum). If anyone can help me thank you it would be greatly appreciated. Also I do suspect it is vanos and I have a rebuild kit ready to rebuild it Incase it is the vanos. The person I bought the car from had a bunch of new parts valve cover gasket oil filter housing gasket and an oil pan gasket. Thanks for reading let me know your thoughts!
 

·
Registered
Joined
·
1,271 Posts
How old is your battery?

I have come to learn that a lot of issues that do not seem to be related to a failing battery actually are. I was almost certain I had a Fuel Pump failing a few weeks ago. It turned out to be my battery. I've had the car for three years and the Ray-O-Vac battery I removed was a 12-month cheapie from Batteries Plus.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
I***8217;ve checked my battery is 12.1 and it is constantly changing as normal and my alternator is at about 13.4 and changing
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
I've checked my battery is 12.1 and it is constantly changing as normal and my alternator is at about 13.4...
That's actually a little low. You should see between 14-14.4 while driving.

Should I go ahead and change the battery and alternator? It was not while driving just at idle. I just hope this is not the torque converter
 

·
Registered
Joined
·
1,271 Posts
Should I go ahead and change the battery and alternator? It was not while driving just at idle. I just hope this is not the torque converter
I would suggest you remove the Alternator and have it tested for free at AutoZone or O'Reilly's.

I just replaced my battery a few weeks ago as it would not hold a charge for more than about 4-5 days. If I charged it and drove the car, the Alternator was putting out 14-14-4 volts so I concluded it was fine - and so far, I'm right.

I'd never suggest throwing parts at a car without first confirming they need to be replaced.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
Okay I figured out the problem finally if anyone was wondering, change or add transmission fluid to your car make sure the transmission is cold and check it on a level surface and fill it until it leaks out. Completely solved most issues I was having. I went ahead and changed the fluid and filter. I have the ZF 5hp-19. Since it didn***8217;t have enough fluid the transmission was struggling to keep the car at a consistent engine speed. Thanks to anyone who has read this thread or replied
 
1 - 9 of 9 Posts
Top