BimmerFest BMW Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
hello folks, last night I tried to start my car, it failed for the first time, but it started second time. but i noticed the rpm gauge was very close to 0, normally it would be somewhere around 0.6-0.7. anyway, I started reversing my car, and the engine just stopped, then the "check engine" light went on. :cry: tried to start my car again, but the engine stopped few seconds after.

5 mins later, everything seems ok, but the engine check light was still on, i was planning to take the car to the dealer for a checkup. however, today the light went off...:confused: so wired


anyone knows what would be the problem? I am still going to take my car to the dealer, but I wanna have some ideas before going there.

my car is 2001 330ci, thanks everyone.
 

·
Registered
Joined
·
4 Posts
Did you have a gas in the tank?
And if there is no Check engine light or any other warning light diagnostic will show nothing. Just keep on driving, and see what will get wrong.
It may be that idle speed sensor is going south.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
yep, gas was full.

the thing is, the check engine light has been lighten on for 3 times for the past 2 weeks, the first 2 times went off quickly after I re-cap the gas cap, but this time the light went on because the engine stopped for some wired reason, that's why I am worried.

thx a lot for your reply.
 

·
Registered
Joined
·
141 Posts
Homer Simpson said:
Did you have a gas in the tank?
And if there is no Check engine light or any other warning light diagnostic will show nothing. Just keep on driving, and see what will get wrong.
It may be that idle speed sensor is going south.
There is no idle speed sensor that I am aware of. Sounds like maybe a cam sensor problem. If the check engine light was on and then went off on it's own, the fault code will still be stored. Get the faults read if you are worried and replace whatever caused the fault.

Andy
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #6 ·
Thanks a lot guys, some said it could be the spark plug, oh well, i will go to the dealer later today see if they could code the problem.

how much to replace the cam sensor if that's the problem? thx
 

·
Keeping it surreal
Joined
·
43,316 Posts
muchswatch said:
Thanks a lot guys, some said it could be the spark plug, oh well, i will go to the dealer later today see if they could code the problem.

how much to replace the cam sensor if that's the problem? thx
Rule out spark plugs....the car would just run like sh!t *all* the time if plugs were the issue....I`d bet on fuel delivery or cam sensor.

Regards,
Bob
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #8 ·
Thanks all, I called the BMW dealer, their schedule is full till thursday, I am gonna go to a local shop first.
 

·
.
Joined
·
8,380 Posts
Add me to the stat...

The car died when as I was turning into a main street from a mall... what's scary was, I was blocking half of the lane and I saw cars racing down the road! I was thinking "what the heck's going on" and the steering wheel was locked. Fortunately I was able to restart the car before people start horning, flashing high-beam and shouting the F words at me.

Since then the "Service Engine Soon" has been staying on. Took the car to the dealer this morning. Another $507 out from my pocket.

I asked them to replace the sun-roof shade clips for the 3rd time, so there goes another $200.

For the first 8 months this year, I've already spent $2000 on just fixing the car, excluding the new tires and oil change.
 

·
.
Joined
·
8,380 Posts
muchswatch said:
ouch, that's expensive. @[email protected] how long did it take for them to repair the sensor? is the "check engine" light went off now? Thx for your reply :)
When I first called and asked them yesterday, they told me it could be done in less than 2 hrs. I think he already knew what's wrong when I told him about the light. Besides, those guys should be "pretty experienced" in replacing them. I took a loaner from them... dropped off mine in the morning and will pick it up by the end of today. They'd better make the light go away by the time I pick it up!

I wonder if this should be part of the VIs... it sounds like everybody's gonna experience it just a matter of time.

A sidenote... the loaner (automatic 325Ci) feels sluggish... man, I'm glad I've got manual on my 323Ci. :p
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #16 ·
Oh, please update once you get your car back :)

wired, the check engine light went off again in my car....what the hell is going on with my car? Gee... it's been 5 times for the past 2 weeks, came on and went off, and on again, then off again.
 

·
.
Joined
·
8,380 Posts
muchswatch said:
Oh, please update once you get your car back :)

wired, the check engine light went off again in my car....what the hell is going on with my car? Gee... it's been 5 times for the past 2 weeks, came on and went off, and on again, then off again.
Got the car back, and yes, the light is off... my car "only" died twice since Saturday and no other symtoms, so I'm just going to assume it's been fixed...

Oh, and earlier I said I wanted them to fix the sunshade roof, and they quoted me 1300 because the frame was bent! I told them it cost more than adding sunroof as an option on a new Bimmer, and they said, "it's the labor cost"... :wow:
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #19 ·
lol...i know, they charge way too much for the labour, that's why I am going to get the sensor replaced at my local shop.
 
1 - 19 of 19 Posts
Top