BimmerFest BMW Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My service required indicator seems to be stuck at 3,100 miles. I am not getting any service warnings but if I go through the menus and check when the next service is due it shows 3,100 miles and has been stuck on that number for about the last 2,000 miles. I mentioned it to my service advisor and he didn't really have an explanation.
 

·
Registered
Joined
·
5,550 Posts
It's a condition based service, not mileage. The engine oil sensor checks the quality of the oil and gives an estimate on the range based on this measurement.
Also for the brake pads. It's an estimate based on guessed brake pad thickness and monitored driving habits. If you always do city driving and the computer calculates the brake pad wear based on that and then you suddenly drive 2000 miles on the highway, the remaining distance won't drop 2000 miles since the brakes were rarely used on the highway. Also the speed of wear of the brake pads might not be equal with the guesstimate of the computer.
 

·
Registered
Joined
·
40 Posts
Same here. Stuck at 3100 for brakes. Service advisor checked out the breaks and said it's no where near replacement.

I was hoping to get a break job before my warranty is up in January, I should be at 40 miles by then.

Sent from my SGH-M919 using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I realize that it is not based just on mileage but it seems strange that it has been stuck on exactly 3100 miles for over 2000 miles of mixed city and highway driving.
 

·
Registered
Joined
·
762 Posts
I realize that it is not based just on mileage but it seems strange that it has been stuck on exactly 3100 miles for over 2000 miles of mixed city and highway driving.
It must be some obscure glitch in BMW's software. My rear brake indicator also stuck at 3100 miles ... the dealer reset it a year ago and it went up to 27k. I've driven ~10,000 miles since then, and the counter is now at 15,000 miles.
 

·
Registered
Joined
·
1,281 Posts
It must be some obscure glitch in BMW's software. My rear brake indicator also stuck at 3100 miles ... the dealer reset it a year ago and it went up to 27k. I've driven ~10,000 miles since then, and the counter is now at 15,000 miles.
That subroutine was programmed in Haiti, using live (at least at the beginning) chickens.
 

·
Registered
Joined
·
5,550 Posts
Now I can't find that document but I read somewhere that these brake pad sensors have 2 trigger levels for pad thickness. Somewhere at 0.6mm and 0.2mm (I can't remember exactly).

I guess what's happening is that the computer guessed the brake pad thickness based on brake usage and now the calculation has reached the "0.6mm" limit but the brake sensors are not triggered yet (ie the brake pad thickness is greater than that). So the computer is waiting for the brake pads to reach "0.6mm".
 

·
Banned
Joined
·
10,015 Posts
Now I can't find that document but I read somewhere that these brake pad sensors have 2 trigger levels for pad thickness. Somewhere at 0.6mm and 0.2mm (I can't remember exactly).

I guess what's happening is that the computer guessed the brake pad thickness based on brake usage and now the calculation has reached the "0.6mm" limit but the brake sensors are not triggered yet (ie the brake pad thickness is greater than that). So the computer is waiting for the brake pads to reach "0.6mm".
Getting somewhere....? First sensor limit reached; rather than buy new sensor, mighta been 'modified' for continued driving pleasure. If recent purchase, prev owner may have avoided expensive brake job by neutralizing sensor. Oy!

Or, pad wear sensor may not be installed correctly.

Best check 'em.

.
 

·
Registered
Joined
·
699 Posts
These systems are not infallible. My front sensors started at 50,000km (brand new in 2012) but have never changed over four years. I replaced my rears two months ago and had the tech check the fronts as well. They still had a lot of wear to go. This time the fronts were re-set at 70,000km and have not moved at all while the rears have decreased by 2000km.
Needless to say my front sensors are either dead (likely), missing (from the factory??) or I brake so lightly they are never used(highly doubtful).
 

·
Registered
Joined
·
587 Posts
There is a software problem with early F10s that showed incorrect brake repair advice and stopped countdown at 3100 miles. The fix was installed via software update. I don't have the bulletin data; I gave my car's files to the new owner with the car.
 

·
Banned
Joined
·
10,015 Posts
There is a software problem with early F10s that showed incorrect brake repair advice and stopped countdown at 3100 miles. The fix was installed via software update. I don't have the bulletin data; I gave my car's files to the new owner with the car.
I wuz all wet and that's good info MWPos - thanks! Making note....
 

·
Registered
Joined
·
150 Posts
At 3100 as well. Back to the dealer for the software upgrade...hopefully no charge to me but I doubt it.


Sent from my iPhone using Bimmerfest
 

·
Registered
Joined
·
360 Posts
My rear brake pads indicator is stuck at 4200(Front is over 25K). Just by looking at the rear wheels, I see alot of pad on it. I doubt that 4200 correct. I am the only driver and only drive it on the weekends I am in town. Not driven hard at all! I have almost 17K miles on a 2011.
 
1 - 15 of 15 Posts
Top