BimmerFest BMW Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
198 Posts
Discussion Starter · #1 ·
After a few months of intermittent "high battery drain" and "sos system malfunction" messages, the warnings finally stayed on for good, so I brought my car in for service. Service rep said they need to upgrade the software to fix it. Based on everyone here wanting to get their software upgraded, I figured I should be happy.

When they called at the end of the day today, they said "...some cars like software upgrades, and others don't behave very well. Your car does not like being messed with." They are going to leave it hooked up over night for 8 to 16 hours doing who knows what. Should I be worried?

I've heard some people saying that, after the progman upgrate, their bluetooth didn't work, lights didn't work, voice commands, etc. Am I in for trouble, or is it normal for it to take a while to get the software upgrade right? :dunno:
 

·
Registered
Joined
·
878 Posts
After a few months of intermittent "high battery drain" and "sos system malfunction" messages, the warnings finally stayed on for good, so I brought my car in for service. Service rep said they need to upgrade the software to fix it. Based on everyone here wanting to get their software upgraded, I figured I should be happy.

When they called at the end of the day today, they said "...some cars like software upgrades, and others don't behave very well. Your car does not like being messed with." They are going to leave it hooked up over night for 8 to 16 hours doing who knows what. Should I be worried?

I've heard some people saying that, after the progman upgrate, their bluetooth didn't work, lights didn't work, voice commands, etc. Am I in for trouble, or is it normal for it to take a while to get the software upgrade right? :dunno:
Do not worry, is normal.
 

·
Registered
Joined
·
198 Posts
Discussion Starter · #5 ·
Software upgrade complete, but it didn't solve the problem. They are going to replace the TCU now. Hope that fixes it all. At least I have a loaner car. Onward and upward...
 

·
Registered
Joined
·
30 Posts
Hi,

Did the TCU replacement fixed it and what version of software did you get?

Software upgrade complete, but it didn't solve the problem. They are going to replace the TCU now. Hope that fixes it all. At least I have a loaner car. Onward and upward...
 

·
Registered
Joined
·
198 Posts
Discussion Starter · #7 ·
Yes, the TCU fixed it. The phone actually works a lot better now. The volume is a lot higher so I can actually hear people when they talk. Before the TCU replacement it was hard to hear with the volume all the way up.

Not positive on the progman version, but based on pictures others have posted of their screen shots after an upgrade, it appears to be v26.
 

·
Hofmeister kink ftw!1!!1!
Joined
·
1,482 Posts
Ive been thru similar issues myself. It's why one really has to think seriously before owning an E60 that is out of warranty. I love the car, but really do not want to pay to repair it.
 
1 - 8 of 8 Posts
Top