BimmerFest BMW Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
After listening to Sirrius for several months, my radio displayed the "call sirius" message. I thought it was odd since I had paid for a year's subscription,

Sirius sent an activation signal, but now I'm missing channels 2,5, and many others. I receive channel 19 just fine.

I've spent hours upon hours on the phone with Sirius to no avail.

I've called the dealership and they say it's Sirius -- Sirius says it's BMW.

Help! I miss my channels!
 

·
Registered
Joined
·
1 Posts
Same issue after channel updates.

I realize this is an older thread, but it is the exact issue I am having.

After the last channel refresh Sirius did in July, the X3 has lost many channels, including channel 184.

My other 2 non-BMW vehicles did fine after the channel refresh.

Started the support process yesterday, and after about 1.5 hours there was no change. We worked through a number of attempts, including canceling and restarting the service, all of which the radio responds to, but no joy with getting all the channel back.

It would be great if anyone with a similar issue could chime in. If the OP has a Sirius reference number for their issue it would be great, as it would be nice to show more than one instance of this....and I am sure there are more.

This one will be difficult to solve, as it is easy for Sirius to blame the radio, which worked fine up until the last channel update.
 

·
Registered
Joined
·
5 Posts
Sirius missing channels, including activation channel

I have the same issue in a 2006 E53 X5.

After listening to Sirius for several years, my radio displayed the toll free "call Sirius" message to activate the radio. I also thought it was odd since I had paid for a year's subscription of Sirius Mostly Music.

Sirius sent an activation signal, but now I'm missing channels 7, 8, 25, 26, 27 (which were all presets, still get 6 on preset), and about half the 80 channels in this package. I also no longer receive the activation "preview" channel.

I've spent hours on the phone with Sirius who have finally concluded this is either a BMW problem or I have used some sort of "skip" function to not see the "missing" channels.

I've called the dealership and they say it's a Sirius issue since I do receive channels.

I have tried completely removing the Sirius unit (so it is not plugged into anything) hoping it might reset itself but there is no change in my received channels.

Any thoughts?

Thanks
 

·
Registered
Joined
·
178 Posts
Something changed. Either something broke on your X3, someone made a hardware change in your X3, or the change was with your service. The last option is the most likely root-cause.

Look into the option of using their phone app ***8211; the audio quality seems better using a phone vs satellite if you have data available. I generally use the phone app when data is available for this reason.
 
1 - 4 of 4 Posts
Top