BimmerFest BMW Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello Everyone!

I just purchased a 2002 X5 a couple of months ago and after reading this website and x5world.com I decided to tackle the sirius retrofit. BTW... my X is non-nav, non-dsp. Anyways... I followed the directions on x5world exactly and got the correct parts from the Dealer and installed them last night. Everything went smoothly until I turned on the radio and found that it did not even recognize sirius at all!!! Has anyone else had this issue? Did the Dealer give me the wrong parts? I did notice that the sirius unit was a little different than the one in the instructions, but everything hooked up fine and the dealer said it was an updated model that replaced the older version. Any ideas on what I could have done?

Here are the things I installed:
New CD Player (Manufacture date of 2004)
New Radio
Sirius receiver
Terk antenna
connecter wires from sirius receiver

Sorry I dont have part numbers right now, but I am at work. I will try to post them later.

Any help would be appreciated.

Thanks
 

·
Registered
Joined
·
6,836 Posts
Check fuses and the wiring. Make sure that the connector in the back of the MID for the CD changer/SIRIUS is plugged in.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Success!

It turns out I had to change the location in the radio from Europe to the US and it started right up! Man... I wish they had put that in the instructions. I wouldnt have stayed up till 2am this morning messing with it.

Thanks for the reply!
 

·
Registered
Joined
·
6,836 Posts
02x544 said:
It turns out I had to change the location in the radio from Europe to the US and it started right up! Man... I wish they had put that in the instructions. I wouldnt have stayed up till 2am this morning messing with it.

Thanks for the reply!
I forgot to mention that. You've provided a valuable reference. :D
 
1 - 4 of 4 Posts
Top