BimmerFest BMW Forum banner
21 - 23 of 23 Posts

·
Registered
BMW 320d F31 M
Joined
·
158 Posts
Discussion Starter · #21 ·
The car has no KCAN in use. That is why there in no KCAN wires in FEM or any other module.

I am trying to connect to the pins specified in the instructions since they were empty and also because the FEM might have KCAN in those pins.

As someone also suggested in other related post, it worked for him.
 

·
Registered
BMW 320d F31 M
Joined
·
158 Posts
Discussion Starter · #22 · (Edited)
Follow-up:

1. Connected K-Can to pins 51 (green) and 52 (orange) using repair pins.
2. Connected ground to the ground "comb" behind the rear seats (driver side).
3. Connected power to fuse 159 in the rear fusebox (fuse 5A).
4. VO Coded the 3AG option.
5. Coded ECUs: NBT_HU, FEM_BODY, REM, ICM, TRSVC
WARNING
: the coding of the ICM went smoothly without errors. However, the car issued several errors regarding the adaptive steering and stability control. I think that we may not need to VO code ICM anyway... so if you are searching for info: don't code ICM unless you need to.

6. Cleared all errors with ISTA. However, the adaptive steering still shows errors in the ISTA module tree.
7. The TRSVC also shows errors because there are no surround view cameras. Note that the module I installed is NOT for surround view and only has one camera input.


8. Note that HU_NBT > EXBOX 3001 > CAMERA_SYSTEM = trsvc . This is the ONLY option that works. I tried ICAM_rvc, ICAM_high, ICAM2_rvc and ICAM2_high and none worked.

9. Conclusion: Rear View Camera is working... hurray! But camera quality in low light condition is too dark. My wife's 225xe camera is way better.

-> If someone knows how to correct the ICM and TRSVC errors feel free to pitch in. :)

-> Also: is there a way to remove the top view of the car and sensors on the screen, so that the camera is shown full screen?


I leave here some images for your delight.

Vehicle Car Plant Motor vehicle Automotive exterior
 
21 - 23 of 23 Posts
Top