BimmerFest BMW Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
i have an engine from a 95 740il and i am rebuilding it and installing it into my 96 540I using everything from my 540I except for the block and heads, will i be running into any problems by installing the M60 instead of the M62 that the vehicle came with.
 

·
Registered
Joined
·
15,902 Posts
There may be slight differences, which may, or may not, cause problems. The 540i is not a USA model - we did not get a '96 540i. But, if you truly have a '97 540i, the earlier engine may not play well with the E39 DME, since it is not OBDII-compliant.

Why are you doing this?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
i bought the vehicle without an engine, i found the 95 740Il engine for 300 dollars, i installed the block with the oil pan in the engine compartment and bolted it to the transmission and engine mounts and everything fit perfect, i than hooked up the intake from the 540 to all the electronics and everything plugged right in, i have everything from the 540 except the block and heads, the 740 did have the OBDII hook up, the only problem i think i may have is the camshaft sensor, the plug for the M62 is different from the M60. I really appreciate all the info that you have for me, and yes you may be right that it is a 97 model and not a 96 540I but by the vin number it says that it's a 96, the last 8 of the vin is VBW51397 and the actual manufacturing or production date is 5/96, thank you soo much again for all the information you may have for me.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top