BimmerFest BMW Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
I just received a replacement 6x9 HK rear deck woofer for my 328is. I ordered this because the previous one was static, but the new one is also static. Any advice on what the problem could be and how to get rid of the static? I have an idea but I want it to be wrong..
 

·
I Am The Machine
Joined
·
20,931 Posts
Bad connections, ground loop, bad channel on the amp. What kind of static?
 

·
Registered
Joined
·
49 Posts
Discussion Starter #3
Phantom,

Does the HK system in the e36 come with a tweeter or no?

If it does, could the tweeter be causing the static?
 

·
Dream Green or die
Joined
·
713 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #10
your head unit or your amp are to blame.
Are you sure? Because I can still here the static when Hifi is off, so doesn't that mean the amp is turned off during that time? Also, its just this one speaker guys, if that helps.
I already had to replace the speaker in the door panel and the static went away for that one.
 

·
I Am The Machine
Joined
·
20,931 Posts
We gave you about 5. You gotta go start doing some digging now and try to find out what's causing it from the ideas we gave you. We can only do so much from the other side of a computer.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #14
We gave you about 5. You gotta go start doing some digging now and try to find out what's causing it from the ideas we gave you. We can only do so much from the other side of a computer.
will do, thanks alot guy for the help.
phantom do you think the tweeter may be the problem cause I found a OEM one on ebay?
 
1 - 14 of 14 Posts
Top