BimmerFest BMW Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2004 525i and the speakers started hissing, popping almost like there a short or loose connection. I can smack on the dash and console and the I drive screen will completely shut off. Anyone have any ideas?
 

·
Registered
Joined
·
294 Posts
Stop smacking the car!!! That never FIXED anything! diagnose it! turn balance and fader controls in an effort to find faulty speaker! remove speaker! test it on the bench with a known good source! then either buy a junkyard replacement or hi to Bavarian Auto Sound and buy a new set...good luck!
 

·
Registered
Joined
·
4,871 Posts
There are likely three possible sources.

First, connectors age and corrode, often the ones connected at the speakers.

Second, less often, speaker cones fail, possibly due to overdriving.

Third, connectors at the amps fail over time. When you say you "smack the dash", you're vibrating a connection.

Clean the connectors, and check the speakers on a bench for cone failure.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks for the feedback. Do you think a bad connection to the speaker OR Amp would also cause the IDrive screen to also go out?
 

·
Registered
Joined
·
397 Posts
In my case, the hissing sound from my speakers was the head unit itself. I didn't have navigation, so it was easy to change. The physical aspect of changing it is not hard with Nav, but I think you'll have to recode a new unit.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top