BimmerFest BMW Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
hey bimmer pals,need some advice.my 99 328i has been with low battery charge for the past 3 weeks when i will try to start it would go to the on position but then the 2nd position where the battery light turns on wont go on therefore it wont start fuel pump and all devices go on tho.everytime i jumpstart it goes on sometimes after a few minutes of charging then when i turn it off for a few mins and attemp to turn back on,nothing,now out of nowhere for the past 3 days the battery turns on with no problem i test it by turning it off and on again and seems like never had an issue.guys at autozone told me that my starter can be bad last week,but now its good,is that possible to fix itself?my buddy told me it can be that the car was sitting for a while so it prolly needed time to fully charge,im kind of afraid to drive long distance with my 2 yr old in the car it might start acting up again or to work,does anybody know what can it be or is it just water under the bridge now,pls help,oh sorry for the long post had to try to be as accurate as possible,
 

·
Supporting Member
Joined
·
1,519 Posts
Check all connections.

Give the battery a full charge.

Check the voltage when off.

Voltage should be around 12.5 depending on how accurate you meter is, with everything off.

Turn everything electrical (head lights, fog lights, ac, stereo, leave the door opne) on and check the voltage.

The battery voltage should stay around high 11 or low 12. If it continues to drop rapidly after a full charge, you need a new battery.

Turn everything off. Start the car. With the car running it should be over 13 then turn everything on and it should be over 13.

If it isn't check all connections, retest. If you don't get 13+ when running it's your alternator.

Our cars do funny things when the battery start to go other things malfucntion.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
thanx

thanx alot im going to check it when i get outside,stupid rain,anyway ive been leaking through my lower radiator hose im gonna buy anew one tomorrow and replace it i also only been using water as my antifreeze for the past 2 weeks lack of money but tomorrow im putting antifreeze coolant hopefully thats the issue thanx again
 
1 - 3 of 3 Posts
Top