BimmerFest BMW Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
maybe 20 minutes into a slow cruise around town noticed some steam coming from right front engine hood pulled over popped lid no steam no warning light drove home all seems fine...? where is the hot/cold indicator? 525i 2005. Thanks. Greggo
 

·
Registered
Joined
·
4,884 Posts
Possible the coolant expansion tank or it's cap is leaking.

Cheap 30 min replacement.
 

·
Registered
Joined
·
1,134 Posts
Cap should spin on 3-4 full turns before getting hard to turn, then finally lock into place when the arrow on the cap meets the arrow on the tank. Take a look at my old&new cap photos at the bottom of this thread - http://www.bimmerfest.com/forums/showthread.php?t=796838 my original cap O-rings were pretty flat, wouldn't hold much pressure anymore so the coolant would get past them and slowly drain out of the car. My only symptom was frequent "low coolant" messages.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #7 ·
ok not to kick a dead horse, final question; so the expansion cap spins to the tight position but will easily turn counterclock wise for a 1/4 turn or so after that initial tightening. I will be on a 4 hour road trip is it acceptable to wrap-da-cap with 10mill black tape to make sure there is no leakage while on this cruise. my brain is swollen.
 

·
Registered
Joined
·
4,884 Posts
ok not to kick a dead horse, final question; so the expansion cap spins to the tight position but will easily turn counterclock wise for a 1/4 turn or so after that initial tightening. I will be on a 4 hour road trip is it acceptable to wrap-da-cap with 10mill black tape to make sure there is no leakage while on this cruise. my brain is swollen.
Buy a cap. It's what, $25 even at a dealer? The cap should turn tight. If it spins, it's broken.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top