BimmerFest BMW Forum banner

Sticky pedal UPDATE

1709 Views 4 Replies 2 Participants Last post by  webguy330i
From my post to the Yahoo! group:

Hi all-

Well I have some semi-positive news to post, although it IS yet another "in the future" type update.

Bill just informed me that BMWNA will (hopefully) be receiving the inventory of new pedal assemblies on Monday of next week (that's a stark 5 days away folks!). At that point he will be calling his "parts" contact to see if the parts have actually arrived, and then he will be calling us all back with yet another update to tell us if the parts arrived for sure.

Once that happens, he will start compiling the list of immediate places (dealerships) where the pedals need to be shipped and start coordinating the replacement effort with said dealerships to make sure they're ordering the correct pedal assemblies.

This is all very promising so I really _really_ hope they pull through for us this time with no more delays!

Trying to remain optimistic,

-Chris
1 - 5 of 5 Posts
Chris -

Nice job man! :thumb:

How long did it take before your car developed the sticky pedal syndrome? I noticed that my pedal seems to "click" (and by this I mean that as I depress the accelerator, the pedal isn't fluid anymore, it actually feels like its clicking/sticking as it goes to the floor) but it isn't too bad, yet. Is this what you are noticing with your car and are you getting your pedal replaced at Towne?
I got the sticky pedal around 6k miles or so, IIRC. And yes you have it! Join the club of over 100+ members that have readily admitted it thus far. :D

I already had Towne replace it once, and it came back within a week. They, of course, will be getting a couple of new pedal assemblies just for folks like you and me. Maybe we could match appointment times/dates?
Ackster said:
Chris -

Nice job man! :thumb:

How long did it take before your car developed the sticky pedal syndrome? I noticed that my pedal seems to "click" (and by this I mean that as I depress the accelerator, the pedal isn't fluid anymore, it actually feels like its clicking/sticking as it goes to the floor) but it isn't too bad, yet. Is this what you are noticing with your car and are you getting your pedal replaced at Towne?
Doh! I was hoping I didn't have it. I first noticed this on the 330i loaner that I have been driving almost as much as my own car. The 330i has it really bad. Mine is probably in the first stages. :(

About the appointment times/dates, that would be ultra cool! I'll take you out for some grub and you can tool around with the PS2 and DVD's. :D I'm picking my car up today from my second round of installs for the stereo. It is really a sickness that I have. I just can't stop buying stuff . . . aaahhhh!

Just let me know when you'll be stopping thru.:thumb:
webguy330i said:


I got the sticky pedal around 6k miles or so, IIRC. And yes you have it! Join the club of over 100+ members that have readily admitted it thus far. :D

I already had Towne replace it once, and it came back within a week. They, of course, will be getting a couple of new pedal assemblies just for folks like you and me. Maybe we could match appointment times/dates?
Dude that would rock so hard. I'll def. be in touch! :thumb: :thumb:
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top