BimmerFest BMW Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
850 Posts
Discussion Starter · #1 ·
Last night I moved my car and had a crackling from the front speakers, I didnt think anything of it at first. When I left I had no sound from the rear speakers so I went into the Logic 7 setting and could not adjust it at all. Then the NAV screen on the right portion would blink and everytime it blinks the fm radio turns on and off. On top of all of that when I turned the car off the screen stays on. I'm wondering if this by any chance could be an ASK module if anyone knows, any help is greatly appreicated.
thanks,
Dennis
 

·
Registered
Joined
·
1,999 Posts
this happened to me once but my radio and the navi display won't turn off after taking the key and locking the car however i had to take the fuse for the ratdio out in the trunk and re insert it and it was fine along with all speakers workin, ASK unit was changed in my car for poping sound from front speakers the passenger door to be exact. and when my navi freezes at the BMW screen i take the cd out over night and in the morning like nothing happend. Goodluck
 

·
Registered
Joined
·
850 Posts
Discussion Starter · #3 ·
I tried the fuse last night but the screen stayed on maybe i pulled the wrong one. I'll try that again I have had this car in the shop 5 times for crackling in speakers and told them everytime to change the ASK unit and they have done everything but that. Speaking of taking the nav cd out when i went in the trunk the nav dvd was still powered up as well. let me try the fuse. Thanks for the reply
 

·
Registered
Joined
·
850 Posts
Discussion Starter · #4 ·
The display unit will not power down now either I've had the car parked for over 2 hours and it is still on, I pulled the nav fuse and radio fuse but no luck is there a display fuse or another fuse box?
 

·
Registered
Joined
·
1,999 Posts
there is another fuse box in the glove , so tight though to reach took me over an hour before to put that fuse back on
 

·
Registered
Joined
·
850 Posts
Discussion Starter · #7 ·
Had it replaced less than 2 months ago, would the amp have anything to do with the NAV screen not working though? or the display staying on for hours after the car is off? My guess is the ASK unit does anyone think that makes sense? I stopped at the dealer this morning they have no idea and scheduled a loaner for Thursday we'll see.
 

·
Registered
Joined
·
721 Posts
Well Ive had my ASK unit and Logic 7 amp replaced and I still get the flicker, I think its the CD Changer or Nav screen going. They told me it has been noted twice so if my screen goes out then I shouldnt have a prob getting goodwill, but I want it replaced now :mad: b/c I want to add NAVTV and I know they wont touch it after that.
 

·
Registered
Joined
·
1,999 Posts
ASK unint is the main cd unit in the centter console
 

·
Registered
Joined
·
850 Posts
Discussion Starter · #12 ·
It was the AMP again caused by a faulty cooling push fan, 2 days to get the AMP 6 days for the fan from Germany all covered under the last 4 visits and 2 amps.....
 
1 - 12 of 12 Posts
Top