BimmerFest BMW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello forum,

2007 750Li, 84,249 miles. Recently got a bunch of work done and everything works really well. BUT...

I have tried closing it manually. Upon doing so I noticed the white wheel gear is cracked and split. So theres my issue I'm sure. But why can't I close it manually? it seems locked into position. Am I supposed to turn on electronics or engine while trying to manually close it?

The sunroof will have an intermittent click sound upon open and close. It will begin closing and stop every 2 inches or so. It will not close fully...EVER. When I try to rest it, it'll open super far back, close half way and stop and thats it. It won't do anything else no matter how long I hold the button in the tilt position. It also seems confused because when I press for it to open, it'll close a little bit, then open. And when I press for it to close, it'll open a little bit and then try to close.

It also bumps into the wind deflector at the front of the sunroof frame, even if I hold it out of the way and remove my hand super fast, it will not close fully. I've heard 2 or 3 really loud metallic pops. The rails are oily looking, not dirt of any kind is in there.

What can I try next? I'd like to DIY this since I literally just got the car today and already it's looking like I'm going to have to drop some serious money on it.

Thank you for any advice. The sunroof is currently stuck open.

Best,
Booshiba
 

·
Registered
Joined
·
298 Posts
You can try replacing the gears, I would suggest going to a salvage yard and getting a replacement. Once that's done you can reset to close automatically

Sent from my H8296 using Tapatalk
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
You can try replacing the gears, I would suggest going to a salvage yard and getting a replacement. Once that's done you can reset to close automatically

Sent from my H8296 using Tapatalk
Would the part from a 2006 750 work? I found a 2006 at a local pick and pull.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
Well I found one near me, picked out the gears from the motor, swapped them and everything works now...sort of.

When I do the reset procedure, it goes back, comes forward, opens half way up and stops. Then upon manually moving it, it doesn't close fully still. It will close and then tilt open and stay stuck tilted open. I manually closed it and it worked so at least it's closed now.
 

·
Registered
Joined
·
298 Posts
Try resetting it, by holding the button up as if ti tilt. Start with it completely closed, it should go through all the positions and end closed. I hope that works for you

Sent from my H8296 using Tapatalk
 
1 - 6 of 6 Posts
Top