BimmerFest BMW Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello ! I have this problem for some time. This winter everytime after i drove the car like 15 20 min and stop it in a parking lot for 30 seconds and put the ignition back on, my water needle goes on red and didnt let me to start the car, when i was driven the car needle was at 90 degree all the time. I discovered that i needed to turn the ignition on and off for several times for the needle to get in the right position. But now when the hot weather came even if it sits in the parking for several hours i need to do this thing with ignition for some times and the engine is cold like the needle remains on blue zone after i start the engine, the car heats a little bit from the sun this thing apears and it wont let me to start the engine. Now when i stopped it i need to wait like 30 60min to get it on and the niddle is like at the 60 70 degrees. To be more specific when is cold ouside it makes this thing but like in 5 10 min i do 2 3 ignition tryes and needle is on the right spot but when is hot outside i will wait longer to start the car. What can i do ? I read several post and they solve this problem with different methods. 1 post was simmilar with my problem and it solve it by changing the DME relay. Others says rost the primary temp sensor is the one that is on engine block. What do you think ? Should i try first with the relay or by changing the sensor? I forgot to say when the needle is on red the battery light is on
1030514
 
1 - 1 of 1 Posts
Top