BimmerFest BMW Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter · #1 ·
Hi guys,

Just want to say again thanks for all the help in the past. I think I may have a reoccuring issue.

Earlier this week, my car stalled in traffic upon reaching a stop. Since then everytime I start the car, the rpms fluctuate like mad. From 400-3000rpms, while in Park or even drive.

Its random when it happens, but happens every single time I start the car. Unlike the issue I had last time, I have a complete different set of errors that come up on my dash, from servotronic malfunction, parking brake fault, to brake (something) drive moderately.


After hooking it up to a computer no real error codes came up. I took out the MAF, still had the problem. Eventually I noticed that the throttle body engages iteself without the car on, just with the key in the ignition. Keeps turning over. So took it to my shop figured its the throttle body, but after swapping with another, seemed to continue to engage on its own.

Does this sound like a DME / ECU related problem? Has anyone ever come across this, any advice or input would be greatly appreciated...


Many thanks fellas!
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #3 ·
Thanks MoPaul, think for me personally, dealer is a last resort...

Do you think a mechatronic software update would help? I read some posts of other 7's have wild fluctuating rpms caused by that....though most of them were in drive.
 

·
Registered
Joined
·
1,688 Posts
I don't know how the mechatronic could affect the throttle body, but since my car just went out of CPO I've not gotten intimate with it and my laptop yet....one would think the only thing that would affect that would be the actual throttle position indicator, and whatever controls the cold idle warm up when you first start the car.
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #5 ·
Thanks - well I guess I'll mention that to the shop, but I think their currently baffled. Right now all they know is im having some sort of communication error with the electronics.

Maybe a trip to the dealer is my only option...
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #6 ·
Well, got word from the shop and their saying its definetely the mechatronics. Saying that they will open and try to salvage the current one in there, otherwise need to buy another. Supposedly, a used one is out of the question, he was telling me if any dust gets in they are of no use, stating their very sensitive. Not sure how valid that statement is, because on ebay some are selling between $300-$500 used, where as its near $2000 at the dealer.

Guys any insight, has anyone else ever changed their transmission mechantronic (computer)? How extensive is it? Any advice or past experience would help greatly...?
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top