BimmerFest BMW Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Battery died on 2004 e46 - may have been orig..

After jump, got chk engin and EML lites. New battery, no diff.

Went Into idle mode, no response to accelerator. Towed to dealer who says computer diag as throttle body and wiring harness replacement $1,700!! Holly cow! What would cause this? Just a dead batry - (proper jump by AAA, not reversed)

Reading, see that there are separate throttle bodies for ea cylinders? Why Would all have to be replaced? Any idea why so much...besides $tealer? figured getting 100k service same time?

Any advice for when I visit dealer in am? What should I ask to see, ask question about etc? Svc advisor just says that's what the computer says!

Had this Great car for 3 years, now 98,000 miles. No probs till now!
All help appreciated?
 

·
tappa tappa toit
Joined
·
4,727 Posts
Well unless you have an M3, you only have one throttle body.

For starters, take the car to an auto parts store and scan it for codes yourself. Then post the codes here for the check engine light and clear the codes using the OBDII tool the parts store lends you.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks, I must have miss identified something else about throttle bodies in doing research. Totally new subject to me! I grew up w distributers and carburetors!

but car is not drivable and at dealership service late sat. It just idles w/out accelator response. Had to be towed.

question...what could have caused this? How to know / trust dealer diagnoses?
Is there physical damage? Might b stupid questions but any help to expand knowledge base is helpful.

I plan on being at dealer service at opening Mon am...just trying to understand what happened and what questions and options to ask b4 paying big bucks for a repair I certainly didn't see coming!

Thanks

JP
 

·
Registered
Joined
·
95 Posts
I highly doubt the engine harness needs to be replace. Since you do have a drive by wire throttle, I would think either the throttle angle sensor is bad on the accelerator pedal or the throttle body itself. Its hard to say unless you have a fancy scan tool to determine which one is bad.
 

·
Cogito Ergo Zoom
Joined
·
3,579 Posts
Ask the dealer to give you the printout of what specific codes it threw and then post them here. If they are unwilling to, have the car towed to a reputable independent.

Like others said, I find it very unlikely that you need a new wiring harness. If that were the case, I doubt it would run at all.
 

·
Registered
Joined
·
623 Posts
Could try just resetting the TB. Turn your key to the "on" position (but do not start the car) for 60 seconds, then start the car. That worked for me when I had the EML and all sorts of codes after I unhooked and rehooked my TB for cleaning. The alternative way to do this that I've heard is you turn the key to the "on" position (but not started) for 10 seconds, then off for 10 seconds, and then start the car.
 

·
ROLL TIDE!
Joined
·
24,034 Posts
A throttle body used is $200 and takes about an hour to install. Do NOT pay them $1700. You could fly me and the part to your house, pay me to do it, and still save $500. Better yet, do it yourself and save $1500
 

·
Bajan Z
Joined
·
14 Posts
I had a similar problem where the EML (limp home mode) light came on and the dealer said it needed a new throttle body plus something to do with the coolant tank sensor. I got the small part for the coolant tank that they had in stock and then the thing worked again. I bought the throttle body anyway and never had to use it (over 3 years ago) so I got one sitting in my parts bin......2000 E46 323Ci Cabrio but you may not need one either.....fault code could show up due to some other (minor) malfunction. Get a second opinion from a good BMW mechanic that is NOT a dealer trying to flog you overpriced parts cuz the computer sez so.
 

·
Registered
Joined
·
27 Posts
I have been dealing with this issue for a year and half...4 tows to dealership. Throwing a p1632 code. TB position sensor has been replaced....they now want to replace the wiring harness.... The original wiring harness in the 2004 E46 was a faulty design that needed to be replaced. Do you have the original design or the upgrade on your car?
 

·
ROLL TIDE!
Joined
·
24,034 Posts
I have been dealing with this issue for a year and half...4 tows to dealership. Throwing a p1632 code. TB position sensor has been replaced....they now want to replace the wiring harness.... The original wiring harness in the 2004 E46 was a faulty design that needed to be replaced. Do you have the original design or the upgrade on your car?
I would replace the entire throttle body first. It is easy, relatively cheap, and likely to fix your issue.

Also, nice how the OP left us hanging. I hate it when noobs do that. Give us the results man!
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top