BimmerFest BMW Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Using:
pszdata lite v58.3
E-Sys 3.27.1

I have made some coding changes to my 2016x1 purchased in Canada / F48 (Baureihe F025) on the HU_ENTRYNAV and KOMBI ECUs.

On the HU_ENTRYNAV I made changes to enable German Language and disabled the legal disclaimer. I have also changed
3004 System_Einstellungen ==> EINHEITEN_MASTER ==>> kombi_l6_neu > hmi so that I can activate the new languages within iDrive.

All is fine until this point:

The next thing I did was program KOMBI -> 3008 PIA_Einheiten -> Funktionen -> Sprache -> deutsch/werte 00 from the default of us

After the KOMBI restarted this is when the problems began--> I am asked to set the time and date every time I start the car, the time shows -:-- and there is an exclaimation mark at the right side of the "efficient dynamics".

Also trying to set the date and time in iDrive is also not working, after setting the values they just disappear. The "Set time automatically" setting also seem to do nothing.

Can anyone shed some light onto this?

Many Thanks!
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #2 ·
Update

I set the KOMBI_CIC back to kombi_mid (original setting) last night and this morning, I was able to set the time in iDrive and this change was also reflected in the instrument cluster. Very strange.

However now when I set the time to 24hr format and the date to dd.mm.yyyy it changes on iDrive but on the instrument cluster, it is still 12hr format and mm.dd.yyyy.

Is this because I changed EINHEITEN_MASTER ==>> to hmi (original was kombi_l6_neu) to make the language settings work?

Is there a way to code it so the changes can be done via iDrive instead of having to code the KOMBI?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
What do you have set for DEFAULT_ZEIT_EINHEIT and DEFAULT_DATUM in HU_ENTRYNAV or ZEIT and DATUM_ERWEITERT in KOMBI?
I have mode these changes and it is appearing correctly now:
DATUM ==>> mm_tt_jj changed to > tt_mm_jj
ZEIT ==>> 12h changed to > 24h
DATUM_ERWEITERT ==>> mm_tt_jj changed to > tt_mm_jj
SPRACHE ==>> us changed to > deutsch

However, before I made coding changes to EINHEITEN_MASTER to hmi in order to allow iDrive to switch to German Language Properly, (if I remember correctly), when I set to either 12h / 24h or the Date Format within iDrive Settings, even the language settings (default English,French,Spanish Only) the KOMBI would be updated as well to reflect those changes.

Now it seems that in order to get the changes to take effect on the instrument cluster the KOMBI must be coded separately, i.e. even if the time appears on the iDrive Navigation Screen as 18:24 11.May.2016 the KOMBI would say May.11.2016 6:24pm, if I selected German on iDrive, the KOMBI would stll be in English unless I code to SPRACHE = deutsch

It appears that the KOMBI and the HU_ENTRYNAV ECUs are not communicating with each other in the same manner.

Is this a trade off for changing EINHEITEN_MASTER from kombi_l6_neu to hmi?

Anyway to overcome this so that changes within iDrive would be reflected inside KOMBI as well and still allow for German language?
 

·
Super Moderator
Joined
·
7,157 Posts
Not sure, but I have the following settings and can toggle languages:

KOMBI: SPRACHE_US_UK: ohne_uk = 00; SPRACHE (LANGUAGE): deutsch = 00
HU_NBT: EINHEITEN_MASTER (UNITS MASTER): kombi_l6_new = 03; LANGUAGE_# (# = 1-16 with language choices) and LANGUAGE_X (X = GERMAN, ENGLISH_UK, ENGLISH_US , etc with options as nicht_aktiv, master, or list).
 

Attachments

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Not sure, but I have the following settings and can toggle languages:

KOMBI: SPRACHE_US_UK: ohne_uk = 00; SPRACHE (LANGUAGE): deutsch = 00
HU_NBT: EINHEITEN_MASTER (UNITS MASTER): kombi_l6_new = 03; LANGUAGE_# (# = 1-16 with language choices) and LANGUAGE_X (X = GERMAN, ENGLISH_UK, ENGLISH_US , etc with options as nicht_aktiv, master, or list).
If I set EINHEITEN_MASTER=kombi_l6_neu then the only languages I can switch between are English (US), French, and Spanish, even though that Deutsch is listed, if I try to select it, it will just go back to English as if nothing happened, so setting to hmi is the way I get it to work, unless there is another way.

SPRACHE_US_UK is not in my KOMBI unit, only SPRACHE.

No biggie though, just thought it would be nice to have it function as before.
 

·
Super Moderator
Joined
·
7,157 Posts
So I am guessing you do not have option to set something like LANGUAGE_GERMAN to list (from nicht_aktiv) and LANGUAGE_4 to deutsch.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
Both LANGUAGE_GERMAN has been set to list and LANGUAGE_4 to deutsch has been set but unless EINHEITEN_MASTER is set to hmi it cannot be selected. It appears in the list but once you select it simply goes back to English; however, if I set it to hmi it affects the KOMBI.
 

·
Super Moderator
Joined
·
7,157 Posts
I am curious, where did you come up with idea to switch EINHEITEN_MASTER to HMI?
Are you interested in being able to toggle between languages or just keep German without having constantly reset clock?
In the OP, you stated that everything was fine until you changed SPRACHE? Why Change?

Did you ever try clearing errors with External transmitter after you coded and received the instrument cluster error messages/ exclamation point?

Ok. So it sounds like you have similar *.ncd's as I do because you have LANGUAGE_GERMAN and LANGUAGE_4 parameters. Do you have matching parameters for each one enabled? What do you have set for LANGUAGE_MASTER.
I am not sure if you issue is related, but I troubleshooted with another forum member when we were trying to figure out how to switch our Navigation voice to English_UK and still be able to toggle displayed/written languages. It turned out SPRACHE needed to be uk. See Change iDrive Language. Though, before my car's software was updated, I had 16 options for SPRACHE in KOMBI; after my update, only deutcsch is option. It may be that uk must be default if I-step version gives option.
 
1 - 9 of 9 Posts
Top