Bimmerfest BMW banner

1 - 20 of 49 Posts

·
Registered
Joined
·
802 Posts
Discussion Starter #1
Just a little curious. There are a lot of posts regarding the top motor failure on the z4's but I wonder who's motor has lasted the longest. List your Z4's year & miles before motor was replaced (if it was). Also if your vehicle garaged or not.

I'll start:

2005 - 84,372 miles on original motor & still going strong - garaged
 

·
Registered
Joined
·
67 Posts
Build date of4/2006 and 82,000, original motor. Garaged all the time and almost never parked under trees. Sorry to say, the top is usually up 95% of the time. Wife's hair and it is too dang hot and sunny around here in the summer.
 

·
edwdmtck
Joined
·
8 Posts
2003, third owner, top failed within months of taking ownership at 62k miles.

Bad first few months of ownership, spent more than the down payment on repairs that I assume the previous owner neglected.

Now garaged mostly, out in light rains I occasionally, never parked under trees, etc, carry car cover in trunk usually.

I'm on the forums reading a lot on various models, but was still unaware of how widespread this top motor failure was until it happened. Now I have pdf's, videos, read hundreds of posts, etc and am thankful for shipkiller and others for their input on the issue. Very disappointing in general but love driving the car.
 

·
Registered
Joined
·
57 Posts
Sept. 03, just rolled over 70K, everything on my Z4 is still original except tires and brakes.
Top goes down in May and up again in Oct. Always garaged.
Has to be 60 or above and sunny before it see's daylight, now an then the top does go up if caught in rain or something to do with the wifes hair.
Oct. through April it's in the pole barn, on a carpet rug, top up but covered with fitted cover.
 

·
Registered
Joined
·
75 Posts
Bought a used '03 with 100k miles. Motor soon began to show signs of failing. Replaced the motor six months later. Live in a small residential bungalow. No garage. Always use a cover now.
 

·
Registered
Joined
·
37 Posts
2006 3.0i with the N52 - 101,100 miles on original motor; still going strong and 100% garaged - expecting her to go anther 200k. Have literally had 1 starter issue with the car. Other than that, proactive about the maintenance. Still on original water pump......
 

·
Registered
Joined
·
79 Posts
2006 - Top motor failed weeks after I bought it. 47K - dealer replaced it for $0.
 

·
Registered
Joined
·
137 Posts
1 Top

Build date is April of 2003. I am second owner, got it at 51K five years ago and now at 65K. Top motor went out in first year I owned it (car would have been nine years old); replaced under extended warranty from dealer. Always garaged with mine ownership, and seldom with the top up unless caught in the rain (twice in five years!)!:drive:
 

·
Registered
Joined
·
255 Posts
2003 Z4 3.0i - 145k miles, currently daily driven and parked outside, no issues

2006 Z4M - 120k miles, daily driven for several years and parked outside, no issues

2006 Z4M - 49k miles, weekend driven and always garaged, no issues
 

·
Registered
Joined
·
448 Posts
2006 z4 3.0si. 89k miles. Weekend driver and garage kept. No issues. I did grease all hinge points last year as a precaution. I also checked the drain plugs to ensure clear.
 

·
Registered
Joined
·
66 Posts
5th owner here

I bought the bucket about a year ago with 172,000. If you can believe it.....I saw the top operate the day before i brought it home.

I picked it up in the rain.....so top was up. The next day, I had to put it down manually and join this forum in order to get help and instructions on the fix.

---yup, I live a charmed life

It looked original when i took it, but who knows
 

·
Registered
Joined
·
12,706 Posts
I can't claim the longest, but maybe I can claim the most motors to date. :)

Original factory motor replaced under warranty by 1st owner approximately 2009. (Wet corrosion failure)

Replacement motor replaced by me May 2014 after I bought the car. (Wet corrosion failure)

Motor replaced again January of this year. (Hydraulic pump bypass valve fractured)
 

·
Registered
Joined
·
682 Posts
2008 3.0si, second owner, first owner from SoCal, I'm in Las Vegas...68k miles, garaged, top gets regular use, motor still good.
 
1 - 20 of 49 Posts
Top