Bimmerfest BMW banner

1 - 20 of 25 Posts

·
30FF <3
Joined
·
2,619 Posts
Discussion Starter #1
Yesterday after a club drive around the mountains, after coming home and restarting the car, I get this error message. Never gotten it before, tried resetting it, it was good for about 15 min then it came back. TPM is greyed out.

Haven't done anything to the tires or brakes recently, only thing I can say that it has been raining for a whole week and I did wash the car yesterday morning, but even so I been driving it and nothing has popped up until now. Ill check the spare tire soon for water, but I doubt its water in there, i check it often.

anything else it could be other than the RDC module ?
 

·
Registered
Joined
·
4,840 Posts
Assuming you're using the actual TPM modules and not the earlier wheel diameter things.

The batteries wear out on the TPM pressure sensor sensors in the tires after about 10 years. Not rechargeable, sensor must be replaced. Aftermarket can be found at a reasonable price after some research. Can be replaced by compressing the bead around the valve and swapping out the unit.
 

·
Nuclear engineer
02/2012 X5 35d M57Y CPO 98K miles NOKIAN WR G3 12K miles
Joined
·
16,902 Posts
***8220;Wheel diameter things***8221; is FTM Flat Tire Monitor adjunct of DSC.

There are a number of TPMS signal protocols not compatible with BMW.
 

·
Registered
Joined
·
4,840 Posts
"Wheel diameter things" is FTM Flat Tire Monitor adjunct of DSC.

There are a number of TPMS signal protocols not compatible with BMW.
Thanks, Doug!

OP: when you order, make sure you tell the supplier your car details and VIN so you get the BMW ones..... Definitely avoid the ones from military Humvees -- they don't fit. Not Unimogs, either. They don't fit. Isetta's didn't have them, nor 504's. Only put the BMW compatible ones on your BMW. :thumbup::thumbup:
 

·
Registered
Joined
·
4,840 Posts
I've had good luck with the $25 433mhz blue ones.
Yes -- mine were $140 the set -- with cheap plastic valves included! Trashed the valves. I believe Huf 433 Mhz, if I recall. Lots of them out there -- wide variation in prices for the same units.
 

·
30FF <3
Joined
·
2,619 Posts
Discussion Starter #9
hmm interesting, so if i purchase some after market ones, is this a DIY type of thing, I wont need a wheel machine to take the tire off?

also there isn't no diagnostics i can run to see which tire it is, rather then do all of them?
 

·
30FF <3
Joined
·
2,619 Posts
Discussion Starter #11
Tire shop charges 10-15 bucks a wheel. I would do all four at once. itm tpms 433mhz metal stem are the ones I bought for $100 for the set off ebay.
oh ok well thats not that bad... ill get a shop to do it. thanks guys :thumbup:
 

·
Registered
Joined
·
4,840 Posts
I'd also hire a shop to do it for that price. I did mine, but had access to a tire machine to push the nearby bead past the valve -- I wanted to learn how. Seems like a crappy job if you don't have access to a machine.
 

·
Registered
Joined
·
4,840 Posts
Not to mention checking the balance afterwards.

Sent from my LGLS755 using Tapatalk
Not sure if I understand.

When the bead near the valve is pressed down to access it, the tire is never rotated on the rim -- and in my case the TPMS sensors were physically identical to the old ones. Can't see how rebalancing is needed. Agree that different weight valves and TPMS would be new balancing, tho.
 

·
Registered
Joined
·
4,840 Posts
hmm interesting, so if i purchase some after market ones, is this a DIY type of thing, I wont need a wheel machine to take the tire off?

also there isn't no diagnostics i can run to see which tire it is, rather then do all of them?
I figure that they all are 10-12 years old, and if one fails, the rest will also do in the year. But yes, tire shops (etc) have a receiver to see which are still transmitting enough.
 

·
30FF <3
Joined
·
2,619 Posts
Discussion Starter #16
hey guys today didn’t get a chance to check the spare tire for water but this happened from a cold start and everything went away after 20 min of driving.

https://vimeo.com/271177819

video shows cluster going haywire with lights and speedo not working, my seat bolsters started moving by its self.

how is this happening all from a sensor ? something tells me it’s not the sensor, maybe battery ? but i’ve checked my battery and it’s 12.8v every morning. while driving i get 13.66,13.8,14.04 voltages (fluctuating)


Sent from my iPhone using Bimmerfest
 

·
30FF <3
Joined
·
2,619 Posts
Discussion Starter #19
Any water leaks anywhere?

Sent from my LGLS755 using Tapatalk
I dont know, but first thing tomorrow morning ill be looking at the spare tire space for the RDC module, I think i have my money on that vs anything else.
 

·
30FF <3
Joined
·
2,619 Posts
Discussion Starter #20
BINGO

windshield washer fluid somehow spilled while i was in the twisties not much came out but enough got to the RDC. Going to dry it off as much as possible.

fingers crossed.

Image1527003803.082462.jpg
Image1527003814.102290.jpg
Image1527003824.018755.jpg


Sent from my iPhone using Bimmerfest mobile app
 
1 - 20 of 25 Posts
Top