BimmerFest BMW Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I am realatively new to the BMW community and I love my 98 540i. Bought the car used from a friend and it has been running great the last 2 months. However, the car has been going in and out of Transmission failsafe mode for the past 2weeks. I took it to a BMW transmission guy and he said the transmission needed to be replaced ($4500). This was more than I expected so I got the car back and it came out of Trans Failsafe mode and was running great after no repairs. Took to anther shop and was told could be due to cooling system needing to be repaired. Was going to have it done anyway so replaced all the belts, filters, thermostat and waterpump and it was working great for a few days. Then it went back into Trans Fail Safe mode so I had a friend read the code with his Peake tool. got code 0b8B Electric Thermostate Control Final stage. :mad::bawling::dunno:

Will this cause the car to go into transmission failsafe mode again or do I need to look somewhere else?

Where is it and how do I change it?

Any help is greatly appreciated. Thanks
 

·
L C B
Joined
·
1,473 Posts
sounds like the electric thermostat is an unrelated problem to me but I'm just a shadetree mechanic. If it comes down to it look into having the trans rebuilt rather than replaced, I imagine it would be cheaper.
 

·
Registered
Joined
·
137 Posts
This just happened to me back in June and thank god I purchased the extended warranty!

To make a long story short, the issue lies within the transmission. BMW and most repair shops feel that it would be easier to swap the transmission rather than tear it apart to get to a sensor (and then TRY and to rebuild it).

If you have access to the tools and know how to replace a transmission, I would suggest doing the work yourself - it's not that difficult!

* I'm starting to notice that this issue is popping up more frequently on the BMW forums, I wonder if this is a common failure with our E39's :dunno:

-D
 

·
Registered
Joined
·
191 Posts
have you recently had the fluid changed? It is very particular to the fluid level and mine was a quart down and give trans failure messages and shifted terrible until I added a quart. No problem and many months/miles since.
 

·
Retired Hotness!
Joined
·
954 Posts
Def check the ATF levels. Also there is a switch for the trans that can go bad as mine did a month ago. It was raining hard and the car suddenly went into safe mode. I cannot remember the name but I will post it up tomorrow.. ong story short, some wires in said switch were dry rotted and shorted together, and would make it go into safe, but they would occasionally be ok and it would run fine for a few min then right back into safe.... If this is your problem you will be able to see it if you go under the car and look along the trans. The whole assemble is about 10 inches long.... Hope we have helped.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top