BimmerFest BMW Forum banner
1 - 20 of 54 Posts

·
I glow in the dark
Joined
·
589 Posts
Discussion Starter · #1 ·
today I was driving and my car was idle on a red light and all of sudden this message pops up in my dashboard "Trans Failsafe Prog" the car still moves but it feels like its out of gear , I have not test it on the highway yet , I was in local street and could not drive that fast , anyone experience the same problem as me or have heard of this problem ? I have a 2003 530i automatic, luckily I still have warranty on my car , I will call up the dealer and bring it , but I was hoping someone might have some info on it . all opinions are welcome thanks.
 

·
I glow in the dark
Joined
·
589 Posts
Discussion Starter · #3 ·
well I think it maybe the battery as well because I have a audio system in my car, JL 500/1 amp and JL 10w6 subwoofer . when that trans failsafe prog came on my car felt like it was out of gears for sure possible starting off 3-4 gear instead of 1 , after I parked the car and went inside my house had dinner came out like 1 hour later I started the car and No more error code and the car ran into first gear this time without any problems, I will still bring it into the dealer and let them check it out. since car is still under warranty will replacing the battery be included ?
 

·
Registered
Joined
·
72 Posts
I had the same problem a couple months ago. I had left the car wash in the message came on I paid it no attention because the car was still running when I got home I pulled out the manual read it perform the check that it prescribes. But when I tried to start the car notting happen called BMW roadside got A jumpstart drove around town to charge the battery parked the car over night. Got in the car to go to work no power at all just the fail safe message. Call BMW roadside again once started drove it to My local BMW dealer. Battery replace for 180.00 no more fail safe message.
 

·
Registered
2000 528it, 2015 435i, 2016 435ix GC
Joined
·
814 Posts
I think the battery is a wear and tear item not covered under warranty. But it has been quite a while since I bought a new car, so what do I know. Maybe they will cover the diagnostics.
 

·
I glow in the dark
Joined
·
589 Posts
Discussion Starter · #6 ·
ok , I think my battery is getting weak due to the fact that I am running the stock amp , and also an aftermarket amp JL 500/1 with JL 10w6 subs this is probably what is draining my battery and I need to upgrade the battery. what good heavy duty batterys are there for audio systems ?
 

·
Premium Member
Joined
·
8,082 Posts
Could also be your alternator. Best to have both tested before blinding changing parts. You are very limited in what batteries will fit an E39...size Group 49 is basically it. East Penn makes an absorbed glass mat battery with 900 CCA's, that is about as big as you can find. Most others are 850 to 875 CCA, the factory oem battery is 875 CCA.
 

·
Registered
Joined
·
214 Posts
Yea...get the alternator checked as well. I had the Trans Failsafe Prog error a couple weeks ago, and it was a dead alternator (draining my battery) so my car wouldn't start. When i jumped it, it would just show this error.
 

·
I glow in the dark
Joined
·
589 Posts
Discussion Starter · #10 ·
I did not get that Trans failsafe program message for about a few months now, all of sudden I got the Trans failsafe program error on my dashboard today, my battery was just replaced about.. 3 weeks ago...... so For sure its not the battery. I have another question, My warranty expired 12/26/06 which I had drop my car off to the bmw dealer and I had told them that I had the Trans Failsafe program error , but error was not on when the car went to dealer ,,he said he will check it and found nothing and said nothng was wrong, it has been about 3 weeks since i got the car back from the dealer , can i bring it back and tell them that they never fixed the problem when my car was still under warranty ? should I call NA BMW customer relation ? I feel that this problem could had been fixed because I had this problem when my warranty was still active and when I got my car back which was after new years 1/4/07 and my warranty had expired. any ideas ? or opinons ?
 

·
Registered
Joined
·
214 Posts
Warranty should cover existing documented problems that occured before the end of the warranty period...but they do need to be documented in the service records.

don't rule out your battery. my trans failsafe prog error was eventually due to a bad alternator. i had the battery replaced, and the error happened again. changed the alternator, and the battery a second time as the bad alternator had cooked the second battery.
 

·
I glow in the dark
Joined
·
589 Posts
Discussion Starter · #12 ·
thanks.. I will call up the bmw place where they serviced my car and tell them the problem and if they give me a problem and wont cover my warranty ...do i call up BMW NA customer relation and let them know the problem ? and complaint ?
 

·
Registered
Joined
·
6,962 Posts
The TRANS FAILSAFE PROG is a default setting to your auto transmission when the computer detects a transmission problem. It could be serious or it could be nothing.
The tranny stays in 3d or 4th gear only. Hence, it's very slow off the line. It is intended to allow you to crawl to a dealer for a fix.

I had the same problem 9 mos ago on a wet wintry day. I took it to the dealer, who charged one hr labor ($100) to read the code and tell me I had a problem (duh!) with my transmission. I left it with them for 48 hours and they could not figure out what was wrong. They even called BMWNA. They recommended a new transmission, to which I replied thank you, NO! I had them reset the computer (luckily, they only charged me the 1 hr labor) and off I went. 9 mos and 9,000 miles later, no problems!

It is not battery related. My car had a "new" battery (only 6 mos old) when this problem occured.

Have the dealer check it out. If they can't find anything obvious, have them reset your computer. If it recurs, then you definitely have a problem.

Good luck!
 

·
Registered
Joined
·
11 Posts
Hi I just read your comment about this message:Trans Failsafe prog and decided to ask advice .I am driving 2002 530I sport Package
I was stuck in the snow I tried to drive forward and reverse but could not get out. I got this message while I was trying. then I got pulled but now my car does not drive properly, does not shift, Its in the 3rd gear all the time and does not go backwords, I went to my machanic he said that i need a trany ,but I still hope I can get out of this without FIXING OR REBUILDING IT.I am really concerned about this issue,I also called bmw dealership they told me that is transmition that needs to be changed .They told me that I blew up my transmition while trying to get out of snow ,what u think about this issue?
 

·
I glow in the dark
Joined
·
589 Posts
Discussion Starter · #16 ·
Hi I just read your comment about this message:Trans Failsafe prog and decided to ask advice .I am driving 2002 530I sport Package
I was stuck in the snow I tried to drive forward and reverse but could not get out. I got this message while I was trying. then I got pulled but now my car does not drive properly, does not shift, Its in the 3rd gear all the time and does not go backwords, I went to my machanic he said that i need a trany ,but I still hope I can get out of this without FIXING OR REBUILDING IT.I am really concerned about this issue,I also called bmw dealership they told me that is transmition that needs to be changed .They told me that I blew up my transmition while trying to get out of snow ,what u think about this issue?
if your car is in good health and you did not do some crazy sheeeit with it... then your tranny is fine and your mechinic is a retard if he told you that you need a new tranny... he obviously know **** about bmw.. i suggest you never bring your car to him.... if you want to fix this problem its very simple.... you need to find someone with a thing to clear the code... you can bring it to the dealer and they will charge you $80 last time i did mine..but that was years ago... now its probably $120.... Ive never had this problem after codes was cleared.. Knock on wood...... the last time I had it was becuz of my...... AMP and subwoofer hook up it was pulling too much juice from my battery and caused this problem... I unhooked my amp from my battery and never had this problem again....

so...if you want a quick fix..then just reset the code... it will drive fine... and if fail trans prog comes back then you got some problems.....

good luck...
 

·
I'm otay. You are not.
Joined
·
1,367 Posts
Mine has done this three times. Once at around 40K, again around 78K, and again around 102K. Each time I just did what the manual said... turn the car off for a couple of minutes and then crank it up to see if the message is still there. Each time I've been good. If your light is always on, I'd say you're in bad shape. That's no diy...
 

·
Registered
Joined
·
6,962 Posts
Hi I just read your comment about this message:Trans Failsafe prog and decided to ask advice .I am driving 2002 530I sport Package
I was stuck in the snow I tried to drive forward and reverse but could not get out. I got this message while I was trying. then I got pulled but now my car does not drive properly, does not shift, Its in the 3rd gear all the time and does not go backwords, I went to my machanic he said that i need a trany ,but I still hope I can get out of this without FIXING OR REBUILDING IT.I am really concerned about this issue,I also called bmw dealership they told me that is transmition that needs to be changed .They told me that I blew up my transmition while trying to get out of snow ,what u think about this issue?
Hakob83
I have a Peake and will attempt to clear your code if you can get to Sudbury. No guarantees as the dealer cleared my code the last time. I have since gotten the Peake as I got tired of paying $100 to have them diagnose a problem for me. I will be home today between 1:00-4:00 and all day tommorrow. PM me.
 

·
Registered
Joined
·
5,293 Posts
Hi I just read your comment about this message:Trans Failsafe prog and decided to ask advice .I am driving 2002 530I sport Package
I was stuck in the snow I tried to drive forward and reverse but could not get out. I got this message while I was trying. then I got pulled but now my car does not drive properly, does not shift, Its in the 3rd gear all the time and does not go backwords, I went to my machanic he said that i need a trany ,but I still hope I can get out of this without FIXING OR REBUILDING IT.I am really concerned about this issue,I also called bmw dealership they told me that is transmition that needs to be changed .They told me that I blew up my transmition while trying to get out of snow ,what u think about this issue?
Its possible that you damaged the tranny in this case, but I get the feeling you might just be low on fluid. Shifting gears gets the fluid moving pretty good, and if the fluid is low you will defenetly get the fail safe mode at some point. How hard were you pushing it? Did you shift to park at all when you were doing this?
 

·
Registered
Joined
·
275 Posts
flyboyy: Your 500 watt amp isn't that powerful, so unless you're using the subwoofer with the car OFF or leaving your lights on - it shouldn't do too much drainage to the battery.

You should, however, run a cap on your system if you don't currently have one.

Watch the battery voltages as you drive and idle and make sure they don't dip too low.
 
1 - 20 of 54 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top