Bimmerfest BMW banner

1 - 3 of 3 Posts

·
Registered
Joined
·
814 Posts
Discussion Starter #1
05 530l Zf6hp19 108k miles fluid/filter/pan changed at 43k, 70k and 100k Lifeguard6 used first time, Pentosin ATF1 was used 2nd and 3rd changes. Have never had a transmission problem going back to delivery in 4/05 as new car.

About every month to 6 weeks I hook the car up to Carly and check for codes. Have been running error free for some time until yesterday. A fault: Timeout PM CAN Code: 005149
No check engine light or any indication anything is wrong.

Have googled to no avail and checked my Bentley.
Bentley is of no help what so ever in this case.

Has anyone run into this fault or code before? Any direction?

Car drives/shifts as normal. Wouldn't know there was a problem if I hadn't checked for codes.
That will teach me to be proactive...

Thanks in advance,
John
 

·
Registered
Joined
·
1,067 Posts
How do you know that the transmission is throwing the error code?

The code reads like the target control unit was not reachable for whatever reason. How many times did the error occur? If the error occurred once then I'm not sure that this is such a big deal at this point.
 

·
Registered
Joined
·
814 Posts
Discussion Starter #3
I agree with you, if the code was present and it cleared, no big deal. In my case, it through a code and I cleared it, ran the car and is present again, cleared and reread for codes and it is present for a 3rd time. My problem/consern is I don't know what the error is. If I am able to determine what it is and it turns out to be of no consequence, then no big deal, however it is a unknown and I do nothing, then I have a potential gotcha.
 
1 - 3 of 3 Posts
Top