BimmerFest BMW Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I was on a road trip today. A couple times when I hit the button to resume speed in cruise control, I got a beep and a yellow light I hadn't ever seen before and didn't know what it was. It 'sort of' looked like a gear.

I did it again and got a message on the console that I have a transmission problem - drive moderately to a BMW dealer. I slowed down - and noticed for the first time the tranny hadn't shifted into high gear. I was running @ 4000 RPM at 60 mph!

I didn't know what to do. I got off the freeway, put the tranny into 'Park' (with a pretty loud clunk) and shut it off. Not knowing what to do... I waited a few minutes and turned the car back on, got back on the freeway and it SEEMED fine.

I took it to a dealer. An hour later they came back and said they had cleared the XXXX (don't remember - didn't understand at the time) and that the car would have to sit for hours to cool down to check fluid levels, etc.

I asked... can I drive it and continue my trip. The answer was 'yes'. I drove 2.5 more hours without incident.

Has anyone here seen this before. If yes... what did you do?

Thanks!
 

·
Resident Curmudgeon
Joined
·
24,122 Posts
How many miles?

How often have you changed transmission fluid?

So you have no idea what code it was? Any plan to find out??

I assume no warranty?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Answering first reply

71000 miles

I do plan to call the dealer and try to get the code - good idea!

Tranny fluid hasn't been changed in maybe 30000 miles

Out of warranty
 

·
Resident Curmudgeon
Joined
·
24,122 Posts
maybe? You guessing? bought it used, assume it must have been done and you just havent done it?

BMW thinking it is good for 100k. Then, when you get to 100k, the SA says "Ooooh, I wouldnt touch that fluid- could make the tranny fail- just drive it till it dies". Wonderful piece of engineering/product design....
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Reply

No, I bought it new. Just don't remember for sure when I did a transmission flush. I know it was during warranty - guessing at the 30,000 part.
 
1 - 5 of 5 Posts
Top