BimmerFest BMW Forum banner

Transmission fail safe mode stuck in 3rd gear just got the codes read,help!

32841 Views 12 Replies 4 Participants Last post by  ill540i
I have a 98 540ia and the transmission is in a limp mode,and the codes i have reade are the following:
Code001:
149 CAN wheel speeds
Code002:
049 symptom,,gear monitoring
Code003:
053 Gear monitoring 3
Code004:
059 stall speed



Any ideas?:mad:

Sent from my MB502 using Bimmer App
1 - 13 of 13 Posts
All I can tell you is that others did this:
- How people tested & resolved transmission "Trans Failsafe Program", aka "Limp Mode" (1) (2) (3) (4) (5) (6) (7) (8) (9) (10) (11) (12) (13) (14) (15) (16)
transmission is in a limp mode
Im being told that the problem most likely might be caused by the speed sensor :confused:

Sent from my MB502 using Bimmer App
Trans Prog Failsafe problems can be caused by sensors, a failing alternator or a failing tranny. Check your alternator. If that is fine, have the tranny reset. This requires a GT-1 or equivalent scanner. If the TPF recurs, then you have a tranny problem.
Thanks i will definately try to get it to the shop sometime next week,i have spoken to a mechanic over the phone and he said they will do all the diagnostics for free and from the codes i told him over the phone he says its most likely to be the speed sensor

Sent from my MB502 using Bimmer App
When you guys say 'speed sensor', which one are you talking about?

I think (but haven't checked) that there's one mounted on the transmission.

Is that the speed sensor you're talking about? Or a wheel speed sensor?
he says its most likely to be the speed sensor
Its the sensor mounted on the transmission

Sent from my MB502 using Bimmer App
Thanks. I should add a picture of that to the pictures of all parts of the E39 thread. I can dig it up if it's out there.
Its the sensor mounted on the transmission
That would be very helpfull

Sent from my MB502 using Bimmer App
Probably the input or output sensor.

Good video for overview of your tranny:

Thanks dvsgene

Sent from my MB502 using Bimmer App
See also:
- How to locate, test, and replace the speed sensor mounted on the automatic transmission (1)
I took my car in and they said that solenoids need to be replaced also

Sent from my MB502 using Bimmer App
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top