BimmerFest BMW Forum banner

Transmission Failsafe Mode w/ Transmission Code 15

88751 36
I recently had my mechanic replace the transmission in my 2001 540iT Sport Wagon based on the diagnosis from Concord BMW. When it was installed, the car dropped into the Transmission Failsafe Program mode and displayed transmission code 15: Pressure actuator failure. This is also generic OBD II code 1748: Manufacturer Transmission Control Unit Malfunction and/or Transmission Control Unit Self Test Failure.
Has anyone experienced this problem? If so, what was the diagnosis?

My mechanic doesn't have the big BMW test set to fully diagnose this issue so I've made an appointment to take the car to Concord BMW for diagnosis.

I also had the transmission control module replaced and reprogrammed. Does anyone know if the transmission failsafe program cuts out a lot of the transmission control module functions?

First off, the shift selector indicator on the dashboard is disabled. According to the service manual, the LEDs are enabled through the TCM. Also, the shift lock solenoid is not operating. I can put the car in any gear without having to depress the brake. The pathway for this circuit also travels through the TCM. Unfortunately I do not remember if those two items worked before I had the transmission replaced.
The sport mode is unavailable and no indicator lights change when I tap the shifter to the left.
Additionally, the parking control assist does not activate when the vehicle is placed in R (possibly indicating an electrical problem vice a hydraulic/mechanical problem with the transmission).

I am trying to avoid another R/R of the transmission and was wondering if it could be the computer interface inside the transmission? If so, can that be replaced? I have verified continuity between the TCM and transmission connector and a visual inspection of the connector pins does not indicate any damage/missing pins.

Even though the car is sluggish from the start (because it is stuck in 4th gear), it drives great.

The last time I had the transmission diagnosed by the dealership, 20 minutes later they said, "We couldn't see anything wrong specifically, BUT you need to replace the transmission." $6000.00 later, I now have a working transmission but I am still having issues. Any input to help isolate the issue BEFORE I take it back to the dealership for their input would be greatly appreciated.

2001 BMW 540iT Sprot Wagon w/ Steptronic 5 speed
ZF transmission part# 5HP24A
:dunno:
1 - 1 of 1 Posts
Wow- sorry to hear. How many miles do you have on the original tranny?:yikes:
"We couldn't see anything wrong specifically, BUT you need to replace the transmission." $6000.00 later, I now have a working transmission but I am still having issues.
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top