BimmerFest BMW Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Hello.

Saturday morning, when I drove to see my family doctor, everything worked fine. Few hours later, as soon as I pulled out my car from parking lot, it started to show symptoms. As the car stopped, the square around the gear position indicator ( P, R, N, D..) flashed and the warning beep was heard. But, the car still drove fine. When I tried to stop the car to see the problem, the car refused to engage to P or R positions. I could only select D or N. I brought the car to the Service, a technician turned on and off the car 2-3 times. Finally, it went to P position, but now it refused to change to any position else.
The service considered it as emergency, but even the emergency line-up is for few days. They won't be able to check my car until next Tuesday.
Is anyone had same problem before?
I will post follow-ups as the service begins working on my car.
At the same time, I asked them to fix the interior trim gap on A-pillar.

BTW, as a loaner, I was offered 323i and 128ic, I picked 128ic. It feels alot better than 323i....Just weather here in Vancouver won't allow top down for next several days...
 

·
Registered
Joined
·
1,926 Posts
Anyone else drive the car? Did u spell any beverages from the terrible cupholders?
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
Anyone else drive the car? Did u spell any beverages from the terrible cupholders?
Nope.
I usually don't let anyone to drive my cars.
Also, NEVER spill anything.
 

·
Everything's Bigger in TX
Joined
·
7,121 Posts

·
Registered
Joined
·
802 Posts
Bummer. Keep us posted.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #8 ·
Dinan Issue?
Could be. I havn't heard anything yet, though.
The service promied to get back to me by Tuesday afternoon,
so I'm trying to be as patient as possible...
I will update as soon as possible.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #9 ·
I got a call from the service yesterday afternoon.
They found that one electric box(module) was faulty and it was ordered to Germany.
So my car will be sitting there for next 2 weeks or so.
I didn't have chance to ask exactly which part was faulty, thou.
I will update as I get more info from them.
 

·
Registered
Joined
·
2,323 Posts
I got a call from the service yesterday afternoon.
They found that one electric box(module) was faulty and it was ordered to Germany.
So my car will be sitting there for next 2 weeks or so.
I didn't have chance to ask exactly which part was faulty, thou.
I will update as I get more info from them.
My X5 5.0 was in the shop for one month after they had to replace a module (the DME).
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #11 ·
Finally, I could talk to my SA this morning after his vacation.
The part is on its way to here, but due to Easter weekend in Canada, it could be delayed to next week.
Anyways, they found that gear shifter assembly was malfunctioning.
It's either not feeding signal right for shifting or not processing the feed signal for shifting.
I hope I will get more detailed info upon recieving the car.
 
1 - 11 of 11 Posts
Top