BimmerFest BMW Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
184 Posts
Discussion Starter · #1 · (Edited)
Has anyone noticed a delay (loss of power) in shifting when accelerating? It is most noticable when accelerating onto a highway. The transmission seems to not be able to "think" as to what gear to be in and causes a serious lag when shifting between gears.
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #3 ·
It cannot be, it is a different gearbox alltogether. It pisses me off none the less!
 

·
Tar Heel Faithful
Joined
·
14,127 Posts
Didn't notice any lag or delays when I drove the X3. The 8-speed auto works fairly well, so perhaps there's something wrong with your specific vehicle that requires a trip to the dealership.
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #6 ·
Please see my post regarding the battery charging light. The a$$hole dealer did not deactivate the transport mode. Being flatbedded to the dealer as we speak.
 

·
Registered
Joined
·
6,596 Posts
Yes, a different gear box but was the box itself the problem before or just the BMW software? Remember the X5 3.0 had a ZF box and the X3 a GM6 box -- yet both had some problems with shifting when they first came out, and beyond in some cases.:yikes:
 

·
Registered
Joined
·
181 Posts
Yes, a different gear box but was the box itself the problem before or just the BMW software? Remember the X5 3.0 had a ZF box and the X3 a GM6 box -- yet both had some problems with shifting when they first came out, and beyond in some cases.:yikes:
HERE COME THE TROLLS AGAIN. Give them an inch and they rear their ugly head. (Is Charlie in the house???)

Lets not start this again for the sake of bitching. It really is old.
 

·
Registered
Joined
·
394 Posts
My X3 shifts perfectly, including getting on the freeways. If someone is having a real problem, go back to the dealership, replicate the problem and insist that they fix it. And don't take no for an answer.
 

·
Registered
Joined
·
3,234 Posts
HERE COME THE TROLLS AGAIN. Give them an inch and they rear their ugly head. (Is Charlie in the house???)

Lets not start this again for the sake of bitching. It really is old.
Yes it does get tiring.
Hey guys, let's stick to the current car under discussion please. I know some of you have had a bad experience a few years ago with the older generation model, but try not to carry your baggage to this section.

As far as shifting problems with the F25, I haven't heard of many in this or the other forums.
To the OP, if you're having a problem, take it to the dealer. It's not normal.
 

·
Registered
Joined
·
10 Posts
I've had no delay in shifting whatsoever. Sounds like a problem specific to your vehicle (unless you are used to faster upshifts, as in a DSG or Ferrari gearbox).
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #12 ·
Problem solved...see above. The car was delivered to us in "transport mode".
The telltale was the battery % charging indicator displayed in the info center.
Someone here tipped me off and I dug further, brought it back. The dealer made good on the situation and the car has been awesome since.
 
1 - 12 of 12 Posts
Top