BimmerFest BMW Forum banner
1 - 18 of 18 Posts

· Registered
Joined
·
807 Posts
Discussion Starter · #1 ·
Well, I'm retrofitting Sirius into my 2001 325i sedan. Note: BMW has a new Sirius receiver model. This model has a single antenna connection for the newer style Sirius antennas. The part # is 65 12 0 398 140. I bought a Terk SIR-MINI and installed it to the rear deck of the trunk lid instead of outside the car (yuk).

I started by purchasing a 2004 OEM cd player from a member who'd upgraded to NAV. I bought the $12 antenna adapter, and installed it a-OK... NOTE: I have the trunk mount IceLink kit, so I just bought this adapter cable from Dension that supposedly just allows the icelink to plug into the Sirius unit for power / connectivity...

Anyhow, after I connected the Head unit, I tested to make sure everything was working.. The mode button successfully switched between Radio / CD / AUX (I wired the aux input into the center console while I had the dash apart) / and my iPod. Excellent start...

So... I turn the car off (didn’t disconnect the battery), and unplug the connections from the back of the CD changer control. I then plug the extension Tom at Dension sent me from the cd changer plug to the corresponding port on the Sirius receiver. I unplugged the 2 wires from the old IceLink piece and toss the piece.. I dont think its needed... Those two plugs fit nicely into the Sirius unit...

So, all connections look good... Turn the key to position 1 as instructed and hit Mode... Nothing... My receiver doesn't say Sirius... After fiddling with the connections and having the same results, I decide to unhook the Sirius receiver and just hook the IceLink back up...

Now the IceLink doesnt work either! Ugh... Hitting Mode now just toggles between the CD player / AUX and radio.. Ugh...

I checked the fuse box, and I didnt see any fuses blown out...

Whats going on. Help?!
 

Attachments

· Registered
Joined
·
8,402 Posts
sna77 said:
Well, I'm retrofitting Sirius into my 2001 325i sedan. Note: BMW has a new Sirius receiver model. This model has a single antenna connection for the newer style Sirius antennas. The part # is 65 12 0 398 140. I bought a Terk SIR-MINI and installed it to the rear deck of the trunk lid instead of outside the car (yuk).

I started by purchasing a 2004 OEM cd player from a member who'd upgraded to NAV. I bought the $12 antenna adapter, and installed it a-OK... NOTE: I have the trunk mount IceLink kit, so I just bought this adapter cable from Dension that supposedly just allows the icelink to plug into the Sirius unit for power / connectivity...

Anyhow, after I connected the Head unit, I tested to make sure everything was working.. The mode button successfully switched between Radio / CD / AUX (I wired the aux input into the center console while I had the dash apart) / and my iPod. Excellent start...

So... I turn the car off (didn't disconnect the battery), and unplug the connections from the back of the CD changer control. I then plug the extension Tom at Dension sent me from the cd changer plug to the corresponding port on the Sirius receiver. I unplugged the 2 wires from the old IceLink piece and toss the piece.. I dont think its needed... Those two plugs fit nicely into the Sirius unit...

So, all connections look good... Turn the key to position 1 as instructed and hit Mode... Nothing... My receiver doesn't say Sirius... After fiddling with the connections and having the same results, I decide to unhook the Sirius receiver and just hook the IceLink back up...

Now the IceLink doesnt work either! Ugh... Hitting Mode now just toggles between the CD player / AUX and radio.. Ugh...

I checked the fuse box, and I didnt see any fuses blown out...

Whats going on. Help?!
... you did not specify if the Sirius unit was working by itself (no ice>link connected) to beging with. :confused:

a) Connect the Sirius unit only (no ice>Link) with the CD Changer port little jumper plugged in (no extension cable) and see if can be recognized. According to BMW you are required to have this jumper plug in if you do not have a CD Changer connected or the unit will be damaged.
- Check that 2 amp fuse of the Sirius unit.
- With a multimeter check if you have power in the red cable of the CD Changer 3-pin connector. If not check radio fuses in the glove box.

b) If the Sirius works alone, leave it connected, turn the car off, remove the positive post of the battery and plug again the CD Changer extension with the ice>Link. Put everything back together and check again. If the Sirius and the ice>Link are incomunicado again, remove the ice>Link and check the Sirius alone.

Now you can see which one (or both) is bad... :(
 

· Registered
Joined
·
807 Posts
Discussion Starter · #4 ·
-I never had the Sirius unit working without the icelink.

-I had the rubber stopper in the Sirius unit when testing that way.

- I did not unhook the battery first. Someone else mentioned that I should I unhook the battery (oops, forgot to do that step)...

- I dont have a multimeter, so I'll try the other steps first and see if that helps... I'll post back more info after I try it tonight.

Thanks!
 

· Registered
Joined
·
807 Posts
Discussion Starter · #5 ·
Technic said:
... you did not specify if the Sirius unit was working by itself (no ice>link connected) to beging with. :confused:

a) Connect the Sirius unit only (no ice>Link) with the CD Changer port little jumper plugged in (no extension cable) and see if can be recognized. According to BMW you are required to have this jumper plug in if you do not have a CD Changer connected or the unit will be damaged.
- Check that 2 amp fuse of the Sirius unit.
- With a multimeter check if you have power in the red cable of the CD Changer 3-pin connector. If not check radio fuses in the glove box.

b) If the Sirius works alone, leave it connected, turn the car off, remove the positive post of the battery and plug again the CD Changer extension with the ice>Link. Put everything back together and check again. If the Sirius and the ice>Link are incomunicado again, remove the ice>Link and check the Sirius alone.

Now you can see which one (or both) is bad... :(
the cd changer jumper, is that little rubber, stopper, correct? So just Sirius should be 3 connections, the power, the other little connector (prob audio output) and then the antenna, correct?
 

· Registered
Joined
·
807 Posts
Discussion Starter · #7 ·
Technic said:
Yes... :thumbup:
cool, ill unhook the battery and attempt to do this again tonight / tomorrow... thanks... any suggestions for mounting it inside the trunk since i have no cd changer opening?
 

· Registered
Joined
·
351 Posts
sna77 said:
cool, ill unhook the battery and attempt to do this again tonight / tomorrow... thanks... any suggestions for mounting it inside the trunk since i have no cd changer opening?
We spoke on the phone this morning - let me know how everything turns out tonight!
 

· Registered
Joined
·
807 Posts
Discussion Starter · #10 ·
sna77 said:
Thanks Tom! As always, great customer service!
OK... working on it now...

having an awful time here... drove an hour and a half to my parents house on cape cod to use their garage... disconnected the battery and still no luck... WTF... i cant get either the icelink or sirius to work. UGH...

Ive tried just the sirius, just the icelink and both... battery full disconnected then reconnected... then i turn key to position #1, and it just goes AUX / Radio / CD player...

ANyone have any ideas????
 

· Registered
Joined
·
351 Posts
sna77 said:
OK... working on it now...

having an awful time here... drove an hour and a half to my parents house on cape cod to use their garage... disconnected the battery and still no luck... WTF... i cant get either the icelink or sirius to work. UGH...

Ive tried just the sirius, just the icelink and both... battery full disconnected then reconnected... then i turn key to position #1, and it just goes AUX / Radio / CD player...

ANyone have any ideas????
Does this mean the Sirius receiver is not working as well? If the Sirius is not activating - the ice>Link cannot work either. The Sirius is the first device in the chain.
 

· Registered
Joined
·
807 Posts
Discussion Starter · #12 ·
Does this mean the Sirius receiver is not working as well? If the Sirius is not activating - the ice>Link cannot work either. The Sirius is the first device in the chain.
tom,
-sirius does not work by itself
-icelink does not work by itself
-neither works when both are connected together....
 

· Registered
Joined
·
807 Posts
Discussion Starter · #14 ·
Success!

Got it. Dumbazz blown fuse on the Sirius receiver! I swear I checked it thrice...

So, I now have Sirius, IceLink a 2004 Headunit with an AUX adapter on my 2001 325...

Woohooo

TOM: Any idea why display now shows IceLink instead of ID3v2 tags?
 

Attachments

· Registered
Joined
·
807 Posts
Discussion Starter · #17 ·
Success!

I just sent Tom an email, but thought I'd post it for members following the thread that might have the same issue:
***************

Tom,
Good news! I don't know exactly why, but Sirius / IceLink with MP3v2 tags are now working! Woohoo...

To recap, what was happening:
-IceLink hooked up as slave device to new BMW sirius unit (single antenna model)
-Sirius worked fine
-IceLink MP3 tags would not work. Radio displayed "Ice_Link_Plus" scrolling
-Only way to control the iPod was to control it via the device itself

How I fixed:
-disconnected the battery.
-unhooked Sirius / Icelink
-Hooked IceLink up in its original config w/o Sirius
-Reconnected battery
-Turned on car... MP3 Tags/ iPod works again..

Now the test...

- disconnected the battery
- rehooked the Icelink / Sirius up in slave configuration (exact same way as i had it before)
- reconnected battery
-Turned car on...

Success! Both devices now work properly!

I now have AM/FM / CD / iPod / Sirius / AUX input going in my car... Haha!

Thanks so much for your help as always.

-Steve

PS: My one suggestion, would be to make that cable that connects from the CD changer controls to the Sirius about 2-3 inches longer... I had to mount my Sirius unit in a weird angle in order for it to reach, and i dont think it would reach for people with the side opening unit.
 

· Registered
Joined
·
351 Posts
sna77 said:
I just sent Tom an email, but thought I'd post it for members following the thread that might have the same issue:
***************

Tom,
Good news! I don't know exactly why, but Sirius / IceLink with MP3v2 tags are now working! Woohoo...

To recap, what was happening:
-IceLink hooked up as slave device to new BMW sirius unit (single antenna model)
-Sirius worked fine
-IceLink MP3 tags would not work. Radio displayed "Ice_Link_Plus" scrolling
-Only way to control the iPod was to control it via the device itself

How I fixed:
-disconnected the battery.
-unhooked Sirius / Icelink
-Hooked IceLink up in its original config w/o Sirius
-Reconnected battery
-Turned on car... MP3 Tags/ iPod works again..

Now the test...

- disconnected the battery
- rehooked the Icelink / Sirius up in slave configuration (exact same way as i had it before)
- reconnected battery
-Turned car on...

Success! Both devices now work properly!

I now have AM/FM / CD / iPod / Sirius / AUX input going in my car... Haha!

Thanks so much for your help as always.

-Steve

PS: My one suggestion, would be to make that cable that connects from the CD changer controls to the Sirius about 2-3 inches longer... I had to mount my Sirius unit in a weird angle in order for it to reach, and i dont think it would reach for people with the side opening unit.
Steve,

Glad everything is in working order. I'll have the SAT cables made longer in the future to your recommendation.

Thanks for the feedback!
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top