BimmerFest BMW Forum banner
1 - 13 of 13 Posts

· Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
On my 2007 335i, the turn signal indicator just started blinking fast and the display also shows a warning bulb sign.
But all the turn signal bulbs seem to be lighting/blinking fine
How do I determine what is wrong ?

thanks
V
2007 335i 6sp
 

· Registered
Joined
·
806 Posts
Check your light bulb one of them is burn.
 

· wooohooo
Joined
·
2,911 Posts
On my 2007 335i, the turn signal indicator just started blinking fast and the display also shows a warning bulb sign.
But all the turn signal bulbs seem to be lighting/blinking fine
How do I determine what is wrong ?

thanks
V
2007 335i 6sp
If someone doesn't say off the top of their head, just google to find out the method to display code on your dash. It will probably start with something like CC-ID . . . Then google that code to see what it's about. This may help you start narrowing the culprit down. You can use resources such as this one:

http://www.endtuning.com/ccidcodes.html

One way to approach this, in my very limited experiences, is the process of elimination. Well I now know how to remove the 4 rear sockets, never touched the front lights yet. My outer ones remove in mere seconds, it's only one tab to depress. The inner sockets on my car require removing the shroud or whatever it's called to access a single nut; it's removal allows the whole thing to come out. I think my outer sockets, with all new bulbs etc, was only . . . $16ish? If it's only a bulb or two, you can probably spend less. (My issue was socket based.)
 

· Registered
Joined
·
40 Posts
Discussion Starter · #5 ·
thank you
found 4 error codes
122 - indicator front right failure
125 - indicator rear right failure
133 - rear right light failure
373 - brake force display right failure

it makes no sense as I checked and verified that all the bulbs are working perfectly...

could it be anything else? all the error codes are pointing to an issue with the right side...
 

· Banned
Joined
·
10,087 Posts
What type of bulbs are you using? Some people replace the regular bulbs with LED bulbs and the cold check needs to be turn off in order to not throw error codes.
True! Computer checks amp draw - if outta spec, error. That of course is voltage.

Whaaaaa? Voltage across a sense resistor yields amperage by calculation.

Now, surprised I am that nobody's put that out in 2 years....

.
 

· Registered
Joined
·
8,097 Posts
These cars don't have flasher units. All lighting is controlled digitally through the FRM.

You probably have a bad contact to one or more of the bulb bases.

Over time the contacts in the bulb holder will lose their tension and make intermittent contact with the bulb base.

Remove the bulbs and clean the contacts. Then gently pry the contacts toward the bulb base. This will restore the tension on the contact so it makes proper contact with the bulb bases.

If you have an E92 coupe, certain MYs were affected by faulty bulb holders. If your model falls under this service bulletin, you need new bulb holders.
 

· Banned
Joined
·
10,087 Posts
These cars don't have flasher units. All lighting is controlled digitally through the FRM.

You probably have a bad contact to one or more of the bulb bases.

Over time the contacts in the bulb holder will lose their tension and make intermittent contact with the bulb base.

Remove the bulbs and clean the contacts. Then gently pry the contacts toward the bulb base. This will restore the tension on the contact so it makes proper contact with the bulb bases.
Yessir!



Anyone know who this is? Oh, yeah....contact cleaner....use THIS!

.....<----- CLICK ME
 

· Registered
Joined
·
5,699 Posts

· Registered
Joined
·
1 Posts
Hello all!

I am a new user on Bimmerfest, but I lurked a couple of times in the past few months. I now have a problem that seems related to this post. Today, I noticed a warning bulb sign. So I went around the car to check which one was burnt, but all of them were fine. Then, I noticed the driver side HID beam flickering on and off. I went back in the car, turned the parking/headlight selector switch to "ON" (it is always on "Auto") and went to check again, still flickering. So I went back in the car, checked out the warning signs.. Wow! Low beam, high beam, warning bulb, clock to zero warnings all alternating!

I shut everything off and came to check this forum. Here are the codes I could get from the procedure I found here.

115
117
118
119
120
121
130
132
134
136
138
375
167

All for the lights, except for the 167 (clock). From what I read, it could be a ground problem I guess..?

Now, I also noticed water stains on the front A pillar (passenger side). This water leak happened on my 2003 330xi also, in this case it came from the sunroof. Could water have leaked inside the fusebox and caused all these failures?

I didn't dismantle anything yet, I'll wait for your input.

Thanks!

Marc Fillion
Ste-Barbe, QC, Canada
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top