BimmerFest BMW Forum banner

two issues with my 2008 535Xi

887 Views 4 Replies 3 Participants Last post by  touche6784
Ok so I have two issues I am wondering if other people have experience with. First is that my Idrive system seems to think my I-pod mini is a CD and will not allow me to play my CDs in the drive. It thinks I have CDs in drive 1,2,3,4 and 6 in a CD changer and has the CD and CD5 greyed out. I also have an issue with the passenger side sideview mirror. On each start up the mirror adjusts to a new position whereas the driver side stays at the same position from before shutdown. I have tried programming with the seat memory and the passenger side mirror just keeps adjusting to a new position as if it does not know where it is. Any ideas? Thanks.
1 - 5 of 5 Posts
I had the same exact issue with the passenger sideview mirror. So when i went to a dealership for regular maintenance last month, i told the SA the issue, they fixed it by reprogramming the mirror, works perfectly now! it now remembers the last position it was in when i start the car.
Ok so I have two issues I am wondering if other people have experience with. First is that my Idrive system seems to think my I-pod mini is a CD and will not allow me to play my CDs in the drive. It thinks I have CDs in drive 1,2,3,4 and 6 in a CD changer and has the CD and CD5 greyed out. I also have an issue with the passenger side sideview mirror. On each start up the mirror adjusts to a new position whereas the driver side stays at the same position from before shutdown. I have tried programming with the seat memory and the passenger side mirror just keeps adjusting to a new position as if it does not know where it is. Any ideas? Thanks.
+1 on reprogramming.
If you are the only driver and don't need to change the seat settings every time you get in the car, you can 'uncheck' the 'last seat position' in the iDrive settings. It might work for your problem. My mirror used to slowly dip down (mirror creep) over the course of a few weeks and resetting the seat memory would not fix it. The 'uncheck' completely stopped the problem.
Thanks for the input. Anyone have any ideas on the ipod issues?
Ok, so here is some more info on my Ipod issue. So I noticed that the ipod cable is not the y cable commonly discussed on the board. It is a single cable that goes to a plastic plate if you will that attaches to where I assume the cd changer would go and the cable hooks to a box behind the glove box with a squarish connector. Is my ipod cable connecting to the cd changer control? Is this even the right way to integrate the ipod or do I just need a reprogramming?
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top