BimmerFest BMW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
My N52 engine has been giving me lots of fun times with the air flow, vanos, camshaft sensor... mixture codes.

Car has 82K miles on it. I've recently replaced both Vanos solenoids, MAF sensor, Spark plugs, Coils, a bunch of the seals. I've been getting a lot of random codes that I clear and then I get new codes. For example: Vapor Leak, Mixture control 0029E1 and 0029E0, 002A15 purge air fine leak. Once cleared never really came back.
002A87 is the main error to always come back (Outlet VANOS, mechanics).

ISSUE: After about an hour or 2 of driving, I get this weird whining sound from the passenger side of the engine. Not related to RPMS directly. It sounds like a pump or air leak of some sort. But if i turn the car off, and restart, sometimes it goes away. Sometimes I have to let the car cool before it goes away.

I discovered this corresponds to the read out of my intake and exhaust camshaft sensor. It shows different values and functions normally, until it zeros out and no longer changes readings. That's when I know the noise is coming. It also means my car is going to idle and die when I slow to a stop. When I restart the car, if I see readings from those sensors, the car runs fine. If those sensors read zero, the car will idle terribly.

QUESTION? Do I just replace both cam shaft sensors? Or is something else making them 'shut off'?

Also, Carly shows both my DISA valves, large and small just sitting at 33%. Should that value be changing?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
528xi 2010. Fun little update... Oil change fixed most of it... I still have a stutter in rpms sometimes at idle... But the whining nosie never comes back. Still worried about the idle issue, but my car doesn't stall at the stop light.
 

·
Registered
Joined
·
1,157 Posts
528xi 2010. Fun little update... Oil change fixed most of it ... I still have a stutter in rpms sometimes at idle... But the whining nosie never comes back. Still worried about the idle issue, but my car doesn't stall at the stop light.
How long did you go between oil changes? You also don't have Disa valves
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
I try to keep it at 7k per change. 2 changes ago it got away from me though and I went almost 15k. Going to do the next one in 2k to see if that helps.
 

·
Registered
Joined
·
214 Posts
...

ISSUE: After about an hour or 2 of driving, I get this weird whining sound from the passenger side of the engine. Not related to RPMS directly. It sounds like a pump or air leak of some sort. But if i turn the car off, and restart, sometimes it goes away. Sometimes I have to let the car cool before it goes away.
....
Also, Carly shows both my DISA valves, large and small just sitting at 33%. Should that value be changing?
The whining sound may possibly [a remote possibility] be a bearing going bad in the A/C pulley. Mine went out rather rapidly so it may not even be the problem with yours.

Our N52 (528 = low hp version) doesn't have the DISA valve.
 
1 - 6 of 6 Posts
Top