BimmerFest BMW Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
i have the.climate control on 60 on both sides. The drivers side temperature is right but passenger side is blowing warm.With no ac on. With ac on same result drivers ice cold passenger side still warm.. Could it be possible the passenger side of the heat control valve is bad. i brought a used one on ebay cause i had no heat got.the heat on drivers side with all temperatures working and heat on passenger but it.just always stays warm with it set to the lowest temperature.. Anyone have a idea did i buy a.bad control valve... Cause everything is working fine on drivers side can one side be bad thank you
 

·
Registered
Joined
·
94 Posts
Have you gone into the ventilation settings in idrive? Check "driver side ventilation" and "passenger side ventilation". You can vary the temp of the air independently from the temp setting on the dash. Set them both the same and then see if you still have a problem.
 

·
Resident Curmudgeon
Joined
·
23,294 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #4
The i drive is all the same blue on both sides . Both set center dash vents and on the same level both on maximum level..It really feels like it is.just blowing motor heat throught tthe passager vent... i can not get it to take the outside air and come out the same temp.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
i am not sure about the freon but i cant get both center vents to blow the same even sitting still just trying to take.in outside temp air with both on 60. Any ideas
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6
This may sound crazy but it feels like the passenger center vent blows warm on top and more normal on the bottom.. The same vent...
 

·
Registered
Joined
·
574 Posts
99% sure you have low freon. Put a little bit more in there with a can that has a "dummy gauge" on it. I bet you'll find you're low, and as you add in freon everything evens out side to side.

Otherwise maybe a blend door is broken (like the motor, sometimes the plastic of the door lets go).
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
i checked the.freon added some just in case by it.was fine around 40. I put it on 60 on both settings pasenger side.still warmer feels warm on top and colder on same vent like the cold and hot are battling each other.
 

·
Resident Curmudgeon
Joined
·
23,294 Posts
i checked the.freon added some just in case by it.was fine around 40. I put it on 60 on both settings pasenger side.still warmer feels warm on top and colder on same vent like the cold and hot are battling each other.
what.s.wit.h..the.lack.of/comprehensible.posts.c? u/ sue? a ?computer?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #10
Its a old phone with a broken screen hard to type and the periods come alot due to it being next to the space bar sorry
 

·
Registered
Joined
·
871 Posts
I had the exact same thing and it was the Freon (as someone mentioned earlier). I know you said you added some, but I was told the system should be evacuated first, then Freon added. I had an Indy do it and now both side blow cold. Good luck.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #12
Did your car actually blow two different temps out of the same vent? Even with fresh air coming through passenger side is hottier and feels like to different temps in that same.vent.
 

·
Registered
Joined
·
24 Posts
Make certain that your driver and passenger climate control are both set on cold. In colder times set them both on heat.
 

·
Registered
Joined
·
5 Posts
Could it not be the vent door actuator?? Mine is blowing cold on the driver's side and warm on the passenger.
I've had an A/C tech check (and fill) the refrigerant. Didn't change anything. Maybe blows a little cooler.
But the passenger side is still warm....
Or could it be the Heater Control Valve??
 

·
Resident Curmudgeon
Joined
·
23,294 Posts
I wonder if Keith fixed it....

Three years ago.

;)
 

·
Registered
Joined
·
23 Posts
I wonder if Keith fixed it....

Three years ago.

;)
My apologies for replying to the June 2018 post and failing to notice that the original was three years old. Shortly after I acquired my X5 and joined the site I was diagnosed with a malignant brain tumor and one of the unfortunate side effects of the chemotherapy drugs and progesterone is cataracts, so I occasionally have trouble reading my computer screen. I'll leave the posting to you experts and go back to trying to read the posts while I'm still able to manage it. Don't want to cause any trouble.
 

·
Resident Curmudgeon
Joined
·
23,294 Posts
My apologies for replying to the June 2018 post and failing to notice that the original was three years old. Shortly after I acquired my X5 and joined the site I was diagnosed with a malignant brain tumor and one of the unfortunate side effects of the chemotherapy drugs and progesterone is cataracts, so I occasionally have trouble reading my computer screen. I'll leave the posting to you experts and go back to trying to read the posts while I'm still able to manage it. Don't want to cause any trouble.
Dont take it the wrong way....everyone gets bit by the 'old post' on occasion.

I didnt berate you, I ended with a smile. ;)

Pull up a chair, join the conversation.

:thumbup:
 

·
Registered
Joined
·
247 Posts
1/2 a can!
THIS! This def fixed my issue last year. But I noticed that it's happening again. But once the whole car is cooled off, then both vents become equally cold... I'm guessing there's a leak somewhere :thumbdwn: but I don't mind it right now since there's a quick fix....
 
1 - 20 of 20 Posts
Top