BimmerFest BMW Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Can anyone please tell me what the DME # should be in my 1992 525it? MFG date 04/92. I purchased the car a month ago & am having problems. When fully warmed up, it hesitates, bogs down & refuses to respond to throttle openings. I perused this board & came up with a DME # ending in 402. My 525it has 173. From what I've gleaned, DME #173 is not the correct one for my model. Please tell me what the correct # should be. BTW, startup & cold idle is perfect. No vacuum leaks, new plugs, good coils, wires, etc, etc. Please respond & thanks in advance.

Michael.
 

·
Registered
Joined
·
134 Posts
buddyiramae said:
Can anyone please tell me what the DME # should be in my 1992 525it? MFG date 04/92. I purchased the car a month ago & am having problems. When fully warmed up, it hesitates, bogs down & refuses to respond to throttle openings. I perused this board & came up with a DME # ending in 402. My 525it has 173. From what I've gleaned, DME #173 is not the correct one for my model. Please tell me what the correct # should be. BTW, startup & cold idle is perfect. No vacuum leaks, new plugs, good coils, wires, etc, etc. Please respond & thanks in advance.

Michael.
Hi Michael. I have a 92 525iT 07/92 and it has the 402. I thought the 173 was for the M20 engine because I had one in my 90 325i. I could see where it might be a problem if you're running it. Anyway, I did an engine transplant in my Touring in June and I'm not using the 402 DME any longer. It's yours for $75 shipped if you want it. Guaranteed good.

Paul
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top