BimmerFest BMW Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
i figured ill put all my issues on this forum to see what people say


CHECK ENGINE LIGHT
Check engine light randomly comes on. IT does come on the majority of the time and always when im either rolling in neutral, at a stop, or rolling in like 5th gear ( anytime im not on the throttle) and the second I touch the throttle it turns off. BUT THE PROBLEM IS THAT SOMETIMES IT DOESNT COME ON!!!!! I plugged in my reset tool i bought from bavauto.com that also reads a small amount of codes and it said its LAMBDA Replaced cats and 02. Also replaced intake manifold gasket. What could this be? Really starting to get on my nerves.

CENTRAL LOOKING SYSTEM
Lastly, my CLS has been acting up. When I unlock the car the first time....it locks itself again, but the second time I unlock it, it stays open. Que?

CHECK COOLENT (warning on dash)
The other day when i flushed the cooling system and refilled it.....I bleed it and everything and its not overheating, but now the check coolent warning is coming on!!! The level is above the minimum cold and warm. Its basically to the max. Could this just be the sensor? Im thinking i got water on the plug or sensor and it shorted out or went bad. Let me know what else it could be.

thanks
 

·
The Biggest P0st Whore!!
Joined
·
2,912 Posts
the check coolant light may just be a stuck sensor or water in the connector. Wait for it to dry and if it is still doing it give the float a poke and see if it is stuck.

really not sure on this but could the CEL be due to a TPS problem?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #6 ·
bimmer dot info said:
the check coolant light may just be a stuck sensor or water in the connector. Wait for it to dry and if it is still doing it give the float a poke and see if it is stuck.

really not sure on this but could the CEL be due to a TPS problem?
Yeah I already let it dry. It's been doing it for the last week or so. Where would the float be? I saw were the plug and connector are. I unplugged it...clean it a little and plugged it backin. STILL DOING IT!

TPS? Dont know what that is exactly. Im thinking either the computer has a serious issue, or i have a bad connection somewhere with the o2 sensor.
 

·
The Biggest P0st Whore!!
Joined
·
2,912 Posts
the float is in the expansion tank. Hard to explain if you have never had it out. but it is a small foam float on the top of the sensor. If your level is correct it should jsut be submerged.

TPS is a throtle position sensor. not very familiar with your engine as i have an M50. But i think yours is still on the throtle body but it is more of an on off switch (mine is a potentiometer). only reason i sugested this is because you mentioned that the light comes on when you are off the throtle.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #8 ·
About the radiator......

will the light come on if the level is too high?

TPS.....hmmm...will have to check if my car even has one.....

thanks a lot for your help thus far
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #9 ·
what would be another term for the TPS or throttle position sensor, because i cannot find the part on realoem.com
 

·
Registered
Joined
·
3 Posts
You should be able to 'reset' your central locking system by turning your key in the driver's side door all the way to the right. the locking system on your 525i should be the same as the one on my 1992 535 (vacuum) and that should at least fix ur CLS problem, good luck w/ the other ones, (i'm clueless when it comes to those).
 

·
The Biggest P0st Whore!!
Joined
·
2,912 Posts
the light should not come on if the level is too high. only detects if it is high enough. Throttle switch is the part on your car. Again i'm not sure this is the problem but it would be worth testing it. Bently manual has info on how to do this.
 
1 - 12 of 12 Posts
Top