BimmerFest BMW Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
248 Posts
Discussion Starter #1
This is so very linked with transmission going faulty and getting stuck in the third gear and transmission overheat eventually.

Every time the car gets stuck in the traffic, the temp starts rising 'ONLY in the hidden menu' where it shows next to 'Outside temp'. Whenever it hits 50c, transmission goes into limp mode and i cant shift the gears manually and nor they shift automatically.

Please note that the outside temp showing on the iDrive screen remains constant in terms of actual temp changes outside the car. However, outside temp indication in the hidden menu changes abruptly and only syncs with the iDrive whenever car is moving.

Is hidden menu outside temp thermostat in fact the thermostat in the transmission cooler assembly?

Wheres is this 'evil' hiding in my car? I have to find this thermostat to keep it cool


Help desperately needed
 

·
Registered
Joined
·
248 Posts
Discussion Starter #3
Forget the Temp Sensor it's probably correct......get your Mechatronic Adapter Seals checked for cracks .. :thumbup:
I hope you are right but my question isnt related to the correction of thermostat but its relation to the a certain temp degree where transmission goes berserk.

This has been observed almost 20 times now that whenever the temp hits 50C (on hidden menu temp reading), the transmission right at that moment goes limp and stops shifting. Gets stuck in 3rd gear and needs really high rpms (beyond 4000rpm) to go the higher gear.
 

·
Registered
Joined
·
1,116 Posts
I hope you are right but my question isnt related to the correction of thermostat but its relation to the a certain temp degree where transmission goes berserk.

This has been observed almost 20 times now that whenever the temp hits 50C (on hidden menu temp reading), the transmission right at that moment goes limp and stops shifting. Gets stuck in 3rd gear and needs really high rpms (beyond 4000rpm) to go the higher gear.
Yes ...i had same issue ....but the Temp issue is a 'symptom' not a cause of the problem.

I had my Mechatronics Adapter Seals checked and both were broken in 3 parts......once replaced all was good again.
 

·
Registered
Joined
·
248 Posts
Discussion Starter #5
Yes ...i had same issue ....but the Temp issue is a 'symptom' not a cause of the problem.

I had my Mechatronics Adapter Seals checked and both were broken in 3 parts......once replaced all was good again.
I'll for sure get mechatronics seals replaced.

But heres another question. Why when im traveling long hauls without getting stuck in the traffic, the transmission acts normal as it should?

By saying this what i mean is, that i dont let the temp on the hidden menu hit 50C and continue managing keeping it lower or rather sync with the actual outside temp (with the iDrive screen)

All it needs is the 50C mark to makes things go crazy. If seals are broken (which i hope is the only reason) then they should leak under any given temperature range and not only at 50C threshold.
 

·
Registered
Joined
·
1,116 Posts
I'll for sure get mechatronics seals replaced.

But heres another question. Why when im traveling long hauls without getting stuck in the traffic, the transmission acts normal as it should?

By saying this what i mean is, that i dont let the temp on the hidden menu hit 50C and continue managing keeping it lower or rather sync with the actual outside temp (with the iDrive screen)

All it needs is the 50C mark to makes things go crazy. If seals are broken (which i hope is the only reason) then they should leak under any given temperature range and not only at 50C threshold.
You are correct it's Temp related....my fault only appeared when the engine got hot .....after an hour or so.....the Mechatronics Adapter Seals go through a 'pressure change' when the transmission gets hot.
 

·
Registered
Joined
·
248 Posts
Discussion Starter #8
Thank you for the link and it sure is informative but my problem is different as my car does goes into D or P cause EGS is working fine.

The issue i have is with my car stuck in traffic and hidden menu 'outside temp' starts rising till 50C. If i start moving from lets say 48C or even 49C max, the temp will come down to whatever the actual outside temp is and the transmission limp wont occur.

Its just 50C mark that once achieved puts the transmission into 3rd gear and things start going crazy onward.

Also if i park the car and take out the key and let it rest for 30 mins, the transmission will act normal until the next longer idle.
 
1 - 8 of 8 Posts
Top